Turbo Not Turning boosting.
Page 1 of 2 12 LastLast
Results 1 to 15 of 22

This is a discussion on Turbo Not Turning boosting. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I bought a 2006 wrx and I noticed that you can't hear the turbo,so i looked at the wastegate actuator ...

  1. #1
    Registered User
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    8

    Turbo Not Turning boosting.

    I bought a 2006 wrx and I noticed that you can't hear the turbo,so i looked at the wastegate actuator and it wasnt moving when gas is presses. I hooked up pressure to it and it moved the actuator. Even manually moving it when car is being revved still doesnt spool up the turbo (i am kind of new to turbos). Any ideas what to check or what could be wrong? Thank you in advance

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,983
    I Support ClubWRX
    Do you have a boost gauge?
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

  4. #3
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,981
    Pull the turbo (or just pop off the DP) and see if there is any shaft play. Does the wheel spin by hand? Is it hard to spin? Should be able to move freely.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  5. #4
    Registered User
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    8
    Quote Originally Posted by Mikie13 View Post
    Pull the turbo (or just pop off the DP) and see if there is any shaft play. Does the wheel spin by hand? Is it hard to spin? Should be able to move freely.

    I just took it off and it seems to spin freely and easy. Here's some pics of it, in case that helps. what could cause the waste gate to not open.






  6. #5
    Registered User
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    8
    Quote Originally Posted by KronosPerformance View Post
    Do you have a boost gauge?

    No don't have a boost gauge yet, might get one at my local auto parts store. Even when driving it, you cant hear the turbo spool up at all.

  7. #6
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,983
    I Support ClubWRX
    Does it drive weird? Pull oddly? Factory Intake Box?
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

  8. #7
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,981
    If the wastegate doesn't open, that means it would overboost...
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  9. #8
    Registered User
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    8
    Quote Originally Posted by KronosPerformance View Post
    Does it drive weird? Pull oddly? Factory Intake Box?
    It has factory air box, no check engine lights, seems to drive good just the turbo doesn't seem to kick on at all.

  10. #9
    Registered User
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    8
    Quote Originally Posted by Mikie13 View Post
    If the wastegate doesn't open, that means it would overboost...


    What would cause the actuator to not open when the engine is revved?

  11. #10
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,981
    well, it has to be under load for one. It won't really open if you just rev it in Neutral.

    Actuator stuck somewhere? Completely hosed or blocked off boost control solenoid?
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  12. #11
    Registered User
    Join Date
    Feb 2011
    Location
    Elkins Park, PA
    Posts
    117
    I could hardly hear my turbo do anything before i put an aftermarket downpipe on it. But it was obvious that it did something.
    Josh
    Blue 08 WRX Limited-Cobb AP Stage 2-AEM CAI-Perrin Short throw/bushings-Turbosmart BPV

  13. #12
    Registered User
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    8
    How do you check the Boost solenoid? Right now the turbo doesnt get hot at all and doesnt make any sound even if i put my ear next to it.

  14. #13
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,628
    I Support ClubWRX
    That's it... I'm writing a FAQ.
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  15. #14
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Have you checked to make sure you don't have a loose hose somewhere? Sounds like it might be as simple as a boost leak.

    As Mikie posted above, if you're looking at it while the car is parked and revving it in neutral, it's probably not going to open. The turbo needs load on it to build enough boost for it to open. I assume this is how you're looking at it since I don't know how you'd do it while the car was driving.....
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  16. #15
    Registered User
    Join Date
    Nov 2011
    Posts
    28
    dude, it sounds like you have a boost leak. if the wastegate doesnt open it would be at full boost (meaning the lever would not move) does the turbo spin freely? i had a problem with low boost it ended up being the wastegate control solenoid (boost control solenoid) the solenoid valve was stuck closed, causing the wastegate to open only allowing 7 psi. you can test it by applying 12v and a ground to the terminals, you should hear it click and be able to blow air through the nipple on the solenoid. or you can put it on test mode by hooking up the green test wires under the driver side dash, turn the key to the on position and it should send direct current to the solenoid. you should hear it click and you should be able to blow through it when it has direct 12 v. sorry if anything sounds funny, been drinkin a lil.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •