Loss of power in higher rpms
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Loss of power in higher rpms within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; When my car is in the 4500 to 5500 rpm range there is a big loss of power and I ...

  1. #1
    Registered User SubiefanParker's Avatar
    Join Date
    Oct 2011
    Location
    Montana
    Posts
    14

    Loss of power in higher rpms

    When my car is in the 4500 to 5500 rpm range there is a big loss of power and I can't figure it out. I just bought this car and don't quite know much about them. Also will removing the intake resonator and installing a silencer delete kit make a difference?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,863
    I Support ClubWRX
    Datalogs?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User SubiefanParker's Avatar
    Join Date
    Oct 2011
    Location
    Montana
    Posts
    14
    I don't have anything to test it. It does not have a stock gauge either I need to get one of those.

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Is the car stock or modified? Does the power return after 5500 rpm or is it gone?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Registered User SubiefanParker's Avatar
    Join Date
    Oct 2011
    Location
    Montana
    Posts
    14
    The car is stock except for catback and the resinator is removed but the ram from the hood is still on. I just shot a video and it seems like the loss of power is between 3500 rpms and 5000. Also when I got out I could smell radiator fluid along with something else I haven't smelled before.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •