Question about my clutch
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on Question about my clutch within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello all, I recently bought a 02 WRX and the clutch started going bad in it just one month after ...

  1. #1
    Registered User ExceedingLife's Avatar
    Join Date
    Oct 2011
    Location
    Wi
    Posts
    51

    Post Question about my clutch

    Hello all,

    I recently bought a 02 WRX and the clutch started going bad in it just one month after i got it. I purchased a F1 Racing Stage 3 clutch and flywheel. They were professionally installed. Now it's been 1000 miles so they should be all broken in since i put it in. Whenever i Rev my engine up to high RPMs before i shift the clutch will sometimes go all loose feeling. Like i can push it down 1/2 - 3/4ths the floor until there is any tension. I am wondering what is wrong here? After like 10 mins if i just drive normally the clutch will tighten back up. Back to how it is normally. I'm now sure what the problem is.

    Thanks for some advice.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Why did you go to a stage 3 clutch? What other mods does your car have?

    Did you have them adjust the clutch to work correctly with the new setup, or did they just put the parts in and away you went? Have you had any adjustment done since the install? Has it worked normally until now since the install?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User ExceedingLife's Avatar
    Join Date
    Oct 2011
    Location
    Wi
    Posts
    51
    I have a few things done to my car like

    Stage 2 (300 H.P.) UniChip
    Xcceleration Short Throw Shift Kit
    Samco Intercooler, Air Inlet and Water Hoses
    Turbo back exhaust system w/3.5" tip, includes downpipe, high flow cat, intermediate pipe
    MRT Flex Joint Uppipe
    GFB Lightweight Pulleys(Crank & Alt.)
    TurboXS Manuel Boost Controller(set to 15psi)
    ScoobySport 3" High Flow Cat
    I also have a few more things done to it.

    The clutch was and still is working fine only when its revved up is when the problem occurs, no i never got my clutch adjusted since its been put in.
    It works fine for normal driving just when i get on it the problem once in awhile occurs.

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Does your clutch pedal have about 1/2" of free play at the top of the pedal stroke?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Registered User ExceedingLife's Avatar
    Join Date
    Oct 2011
    Location
    Wi
    Posts
    51
    yes it does feel like it

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Although you definitely dont have to some guys disconnect the clutch line when they remove the slave cylinder off the bellhousing. Perhaps they didnt bleed the clutch or something. its easy enough to do and it might be a place to start. Does the car shift smoothly into every gear or is there clashing or anything? also make sure that little spring is installed between the clutch fork and the bracket somewhat under the throttle body...

  8. #7
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,712
    I Support ClubWRX I Support ClubWRX
    +1 I would try bleeding the clutch first.



    And I didn't realize there were still Unichips floating around out there.. I figured they had all burned up years ago, lol.

  9. #8
    Registered User ExceedingLife's Avatar
    Join Date
    Oct 2011
    Location
    Wi
    Posts
    51
    Ok, lol i bought my car with basically all the upgrades except HIDs my new clutch and flywheel and it didn't have a system when i bought it to.

    Yes my car shifts very smoothly into every gear without any problems.

    I don't know much about a unichip ha would you recommend upgrading it or something?

  10. #9
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,712
    I Support ClubWRX I Support ClubWRX
    We just reprogram the ECU these days, Unichip is old school. I suppose as long as it's still working you don't have to get rid of it, but a good pro tune will always be better than an off the shelf map.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •