What The F*&% is wrong??!
Page 1 of 2 12 LastLast
Results 1 to 15 of 23

This is a discussion on What The F*&% is wrong??! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; When at 5-7k rpm's in 2nd, 3rd, and, 4th gear, my completely stock '04 WRX spudders.. it wont go through ...

  1. #1
    Registered User
    Join Date
    Jul 2011
    Location
    Phoenix
    Posts
    18

    What The F*&% is wrong??!

    When at 5-7k rpm's in 2nd, 3rd, and, 4th gear, my completely stock '04 WRX spudders.. it wont go through the 5-7k rpm range smothly, it seems like a transmission problem almost like it's slipping but i dont feel anything on the shifter just the engine spudders. It came up with an check engine light once.
    Whats wrong!!??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,335
    I Support ClubWRX
    Tell us the check engine light code.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Jul 2011
    Location
    Phoenix
    Posts
    18
    Quote Originally Posted by SD_GR View Post
    Tell us the check engine light code.
    I would, but I don't know how to check it. It went away after I turned the car off then back on.

  5. #4
    Registered User
    Join Date
    Jul 2011
    Location
    Phoenix
    Posts
    18
    I did accidentally fill it with non-premium gas a tank ago so i added two octaine boost bottles to try to get it back up to premium intead of dumping the tank of non-premium gas, and when that tank was 2/3 gone it started to do this. I have used premium every tank before, I just goofed on that one.

  6. #5
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Take it easy until you burn the rest of that tank out, no high RPM's or high loads. Fill it with premium, then reset your ECU. Try again. If problems persist let us know.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  7. #6
    Registered User
    Join Date
    Jul 2011
    Location
    Phoenix
    Posts
    18
    Quote Originally Posted by Anub1s View Post
    Take it easy until you burn the rest of that tank out, no high RPM's or high loads. Fill it with premium, then reset your ECU. Try again. If problems persist let us know.
    Ok ill try that, how do I reset my ECU?

  8. #7
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,950
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by RikRCar21 View Post
    Ok ill try that, how do I reset my ECU?

    Remove the battery cable and depress the brake for a few seconds. Octane booster doesn't really work BTW.. unless you used like a gallon of toluene, that's what I used to use as injector cleaner/octane booster.

  9. #8
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Or even easier, just take it to a local auto parts store and ask them to pull the code and clear it for you. They'll do it for free. Post the code up here when you're done.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  10. #9
    Registered User GarrettKoonsman's Avatar
    Join Date
    Apr 2009
    Location
    CO
    Posts
    2,664
    Quote Originally Posted by RikRCar21 View Post
    I did accidentally fill it with non-premium gas a tank ago so i added two octaine boost bottles to try to get it back up to premium intead of dumping the tank of non-premium gas, and when that tank was 2/3 gone it started to do this. I have used premium every tank before, I just goofed on that one.
    For future reference.....do not do this, ever. A $50 tank of gas is nothing compared to blowing a motor. My guess is that is exactly what caused your problem
    2003 Midnight Black Pearl WRX Sedan
    200.7 AWHP Protuned Stage 2 at 5400ft above sea level
    Bugeye Mafia Member #225
    Mods
    Pics

  11. #10
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,950
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by GarrettKoonsman View Post
    For future reference.....do not do this, ever. A $50 tank of gas is nothing compared to blowing a motor. My guess is that is exactly what caused your problem


    Theoretically you could fill your tank with 87 and as long as you don't beat on the car and stay out of boost it will be fine until you can run enough out to top it off with 93. I'm guessing there was a WOT event (or several) with the bad gas that was a precursor to the problem.

  12. #11
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,773
    I Support ClubWRX
    Quote Originally Posted by RikRCar21 View Post
    I did accidentally fill it with non-premium gas a tank ago .
    Unless you live in Jersey,this should never happen to you.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  13. #12
    Registered User GarrettKoonsman's Avatar
    Join Date
    Apr 2009
    Location
    CO
    Posts
    2,664
    Quote Originally Posted by MainFrame View Post
    Theoretically you could fill your tank with 87 and as long as you don't beat on the car and stay out of boost it will be fine until you can run enough out to top it off with 93. I'm guessing there was a WOT event (or several) with the bad gas that was a precursor to the problem.
    Theoretically yes, I still would never do that though. Anything other than 91 goes into my tank (Colorado doesn't have 93) and its getting drained.
    2003 Midnight Black Pearl WRX Sedan
    200.7 AWHP Protuned Stage 2 at 5400ft above sea level
    Bugeye Mafia Member #225
    Mods
    Pics

  14. #13
    Registered User MakeItRoar's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Illinois
    Posts
    321
    From what I've heard, octane booster only increases the octane somewhere around 1/5 of an "ocatane point" or whatever the unit is per bottle.
    2006 WRX Limited -Pro-tuned VF-39, STI TMIC, STI factory I/C Sprayer, Throttle body Coolant Bypass, STI Exhaust, SPT Short Ram Intake, SPT Upper Front and Rear Strut Bar, Red Samco Radiator Hoses, STI Trunk, SPT Short Shifter, Aftermarket Rotors, Lamco Turbo Gauge, Catless Downpipe, Hella Supertones, RallyArmor Limited Edition Pink UR Flaps, 35% Tint, Grounding Mod, Walbro 255 Fuel Pump, SPT Heat Shield STI Piston Shift Knob!
    Hawk-Eye Alliance #430

  15. #14
    Registered User
    Join Date
    Jul 2011
    Location
    Phoenix
    Posts
    18
    Im having the fuel emptied today, My plan is to fill up with premium, change out the spark plugs (its about time anyways), then reset the ecu... Ive been keeping it under 3k rpms lately, does anyone think I did any real damage? I ll get the check engine code today too and post it.

  16. #15
    Registered User GarrettKoonsman's Avatar
    Join Date
    Apr 2009
    Location
    CO
    Posts
    2,664
    hard to know if there was damage done until you have changed those things and see how it runs. Keep it under 3k for the first fifty miles or so to make sure all the bad fuel is gone from the system
    2003 Midnight Black Pearl WRX Sedan
    200.7 AWHP Protuned Stage 2 at 5400ft above sea level
    Bugeye Mafia Member #225
    Mods
    Pics

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •