Losing oil...
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Losing oil... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Losing about a half quart every 1700 miles. White smoke on start up when given gas. No power/boost loss at ...

  1. #1
    Registered User WrRexgoliath's Avatar
    Join Date
    Aug 2009
    Location
    Denver, CO
    Posts
    78

    Losing oil...

    Losing about a half quart every 1700 miles. White smoke on start up when given gas. No power/boost loss at all. Is this normal due to oil cooled turbo?
    04 wrx wagon, Cobb stage 2, catless all the way back

    Sent from my SCH-I510 using Tapatalk

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,959
    I Support ClubWRX
    Quote Originally Posted by WrRexgoliath View Post
    Is this normal due to oil cooled turbo?
    No. However the rate of oil loss you report is normal.

    Having a normal oil loss rate doesn't mean you don't have a leak or are not burning oil; it simply means the loss rate is acceptable even if you had no problems at all.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    Do a compression test. Also what oil are you using? Sometimes switching to a slightly thicker oil will reduce consumption.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  5. #4
    Registered User WrRexgoliath's Avatar
    Join Date
    Aug 2009
    Location
    Denver, CO
    Posts
    78
    I don't think I'm losing compression from a warn ring or seal of amy kind because even after 5000 miles the oil is still amber, which I am very happy with I guess I was just checking with everyone if a half quart every 1700-2000 miles is normal with the 2.0L's. Donkey I live in Chicago what do you run weight wise and is going up to 10W going to bring any issues I should consider?

    Sent from my SCH-I510 using Tapatalk

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    5w-40 or 0w-40 would be my choice.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •