Can EGT code from Uppipe cause sluggishness?
Results 1 to 5 of 5

This is a discussion on Can EGT code from Uppipe cause sluggishness? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My 04 4eat wrx has been running very sluggish lately, i have an hks uppipe with an egt bung in ...

  1. #1
    Registered User Rgw2kx's Avatar
    Join Date
    Oct 2010
    Location
    Ohio
    Posts
    53

    Can EGT code from Uppipe cause sluggishness?

    My 04 4eat wrx has been running very sluggish lately, i have an hks uppipe with an egt bung in it with the sensor still installed (no resistor mod) so of course i am getting high exhaust gas temp codes. can this be the problem behind my car's sluggishness?

    (and for those who have seen my previous posts, i havnt gotten the compression/leakdown test done yet, car is in the shop right now and i will have them do it soon, just wondering if this is a possible cause too)

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,143
    I Support ClubWRX I Support ClubWRX
    Are you sure you're not getting a low exhaust gas temp code?


    All the EGT sensor is used for is to throw a CEL (basically) so input from that is not going to cause any problems as far as how the car runs. However, if you are in fact getting a code for high exhaust gas temp then there is something else wrong. EGTs measured in the uppipe will be much lower without the catalytic converter in there. High EGTs is a sign of lean condition.

  4. #3
    Registered User Rgw2kx's Avatar
    Join Date
    Oct 2010
    Location
    Ohio
    Posts
    53
    oh ok. the code im getting is P0546 Exhaust gas temperature sensor circuit high bank 1.

    i was just wondering if the sensor throwing up lights could be telling my ecu to go easy.
    in that case do you think it could be a bad injector/coil pack/fuel pump?

  5. #4
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    EGT won't cause limp-in mode?
    Stink eye mob #727
    2011 WRX DGM Hatch, Protuned Stage 1

  6. #5
    Registered User Rgw2kx's Avatar
    Join Date
    Oct 2010
    Location
    Ohio
    Posts
    53
    thats what i was wondering, ok thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •