Rough idle, stalling,
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on Rough idle, stalling, within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Greetings, I'm having some serious problems with my ride, and I'm hoping someone can guide me in the right direction, ...

  1. #1
    Registered User
    Join Date
    Aug 2011
    Posts
    1

    Rough idle, stalling,

    Greetings,

    I'm having some serious problems with my ride, and I'm hoping someone can guide me in the right direction, here's the info on my ride:
    -02 WRX Sedan, about 128k miles
    -Vehicle is completely stock except for a Fujita intake installed about 3 years ago
    -Always use 93 octane fuel

    About 6 weeks ago, started up the car and noticed it was idling a little rough. Started driving, idling got worse and worse. Then the car would not accelerate, the CEL was intermittently blinking, and finally, the car would not idle at all. I could start it back up, but it just wouldn't idle.

    Took to a Subaru dealer, and they said there were no fault codes stored even tho I saw the CEL blinking. They changed the plugs, fuel filter, and sent me on my way.

    One week later, exact same problem & symptoms, only I noticed a smell of raw fuel under the hood. Took to another Subaru dealer who also said there were no fault codes stored. They swapped the positions of the coils, and sent me on my way.

    Car just did the same thing again a week ago. Took back to the 1st dealer who now wants to replace the coils, saying they still can't find any fault codes, and are hoping that replacing the coils will fix the issue.

    I'm not too keen on the idea of blindly replacing parts in car until the issue is gone. Does anyone have any ideas what the hell is going on? Any help would be appreciated.

    Thank you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User lytlec's Avatar
    Join Date
    Jan 2009
    Location
    Central PA
    Posts
    4,308
    My car was stalling and then it wouldn't start...I replaced the crank position sensor ($60) and it fixed all my problems. I can't say for sure that's your problem but it's a cheap start!
    <-------- Taylor Swift.
    2006 WRX 330whp. 300wtq. Slow.
    Hawk-Eye Alliance #137
    First Mods...what to do.
    Subaru Guide

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •