Misfire HELP!!
Results 1 to 3 of 3

This is a discussion on Misfire HELP!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Im new to subaru and have a 04 subaru wrx ej20 that was rebuilt due to bad rings at no ...

  1. #1
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72

    Misfire HELP!!

    Im new to subaru and have a 04 subaru wrx ej20 that was rebuilt due to bad rings at no cost bc of warrenty it has a greddy evo 2 exhaust k&n typhoon and turboxs recirculating rfl and before the rebuild i would have a really bad miss and the CEL showed cylinder 1 misfire and i had the mechanic install new plugs and check the coils and he didnt check the coils -.- but after the rebuild he flushed the injectors and had a fuel treatment and i drove it the day after i got it back and drove maybe 50 miles and engine was warm and starting stuttering and missing like it did before and now the CEL has the same misfire!! any suggestions?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,044
    I Support ClubWRX
    Yes,read the sticky at the top of the page......

    IF YOU HAVE A MISFIRE CODE ,PLEASE READ THIS!!!
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72
    Took the car for another drive today and same issue after the engine was warm and also a burnt oil smell prob from when the engine was rebuilt takin to garage tomorrow for plugs and coils :/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •