high idle
Results 1 to 7 of 7

This is a discussion on high idle within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i decided to change my tranny fluid on my '04 wrx and that was the easy part. I had trouble ...

  1. #1
    Registered User
    Join Date
    May 2011
    Posts
    26

    high idle

    i decided to change my tranny fluid on my '04 wrx and that was the easy part. I had trouble putting my TurboXS back on and think i might even have a boost leak but not sure.

    my problem now is that my idle is close to 2k when car is just sitting. When i went for a ride i went in to boost and after i went from third to fourth gear rpms surged

    any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,983
    I Support ClubWRX
    Check your throttle body cable, especially for the cruise control. It may be pinched.
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

  4. #3
    Registered User
    Join Date
    May 2011
    Posts
    26
    what am i looking for? cables look ok i guess


  5. #4
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,983
    I Support ClubWRX
    Its hard to tell from that picture but while the car is running, try and push the throttle down and see if you hear it closed. Also while its off, see how much slack is on the line itself. If I remember correctly, my lines were about equal length and yours seems to be one is shorter and one is longer.
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

  6. #5
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    Sounds like a vacuum leak to me. I would check vacuum hoses, grab some throttle body cleaner or brake clean and spray around.
    Stink eye mob #727
    2011 WRX DGM Hatch, Protuned Stage 1

  7. #6
    Registered User
    Join Date
    May 2011
    Posts
    26
    well looks like its the cruise control cable...if i push down idle goes back under 1k. I think i also have a vac leak as i got the overboost code last night. I'll have to check all lines to make sure i did not tear one.

  8. #7
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,983
    I Support ClubWRX
    There you go
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •