wrx eratic idle, CEL list. tryna figure this out..P0851, P1153, P1152..
Results 1 to 4 of 4

This is a discussion on wrx eratic idle, CEL list. tryna figure this out..P0851, P1153, P1152.. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; 05 wrx, stage 1, catback, cobb intake Fixed my power issue (stock uppipe was clogged by a broken apart cat... ...

  1. #1
    Registered User Bblue Rrex's Avatar
    Join Date
    Aug 2010
    Location
    Pennsylvania...woo
    Posts
    141

    Exclamation wrx eratic idle, CEL list. tryna figure this out..P0851, P1153, P1152..

    05 wrx, stage 1, catback, cobb intake
    Fixed my power issue (stock uppipe was clogged by a broken apart cat... ) so i played safe and got a used td04 mated to a 2.5in catless UP.

    Now im having these weird a** idle issues...cold start the car idles up to around almost 2.5k then drops and sits steady between 1400 and 1800. after warming up and driving a bit If i put the clutch in the rpms go up and down about 500 then level out at about 1700. Sometimes if im driving on the highway in say 3rd gear and im at about 4k rpms put the clutch in to shift to 4th and the rpms stay at 4k or go a little higher...

    and after drriving for a while sometimes ill come to a stop and my cars idle will drop (still high though..about 1200rpms) and lope between 1200-1300 and sound cammed, CEL comes on instantly when it does it. But scanned with my AP no codes show.

    Had it doingg this last night, put her in test mode, then scanned the codes and this is what i got.

    P0851 - Neutral Control Switch Input Circuit Low
    P1153 - o2 Sensor circuit range/performance High (bank 1 sensor 1)
    P1152 - o2 Sensor circuit range/performance Low (bank 1 sensor 1)
    2002 WRB WRX
    Bugeye Mafia #335
    High Mileage Club 106K

    My Pics

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Bblue Rrex's Avatar
    Join Date
    Aug 2010
    Location
    Pennsylvania...woo
    Posts
    141
    Bumpidyy

    Also, when the car acts up and pops a CEL with no code and sounds cammed I popped the hood unplugged the MAF and 1 out of like every 5 times it would stall but the other times it would stumble pick back up idle a little higher but sound better and not lope like it was...someone said this means my maf is bad? Any idea? Thanks
    2002 WRB WRX
    Bugeye Mafia #335
    High Mileage Club 106K

    My Pics

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    a bad neutral switch can def. cause an erratic idle, I have seen this more than a few times on Subarus in general. If you have access to a decent scanner you can actually plug it in and watch the status of the neutral swtich as you switch it in and out of gears, so the diag. of this switch is pretty much self explanitory. this is the direction I would go first, and Ive worked on thousands of these things haha, you could also go the route of clearing all the codes and see which ones come back first...

  5. #4
    Registered User Bblue Rrex's Avatar
    Join Date
    Aug 2010
    Location
    Pennsylvania...woo
    Posts
    141
    Quote Originally Posted by EvoEatr View Post
    a bad neutral switch can def. cause an erratic idle, I have seen this more than a few times on Subarus in general. If you have access to a decent scanner you can actually plug it in and watch the status of the neutral swtich as you switch it in and out of gears, so the diag. of this switch is pretty much self explanitory. this is the direction I would go first, and Ive worked on thousands of these things haha, you could also go the route of clearing all the codes and see which ones come back first...
    The CEL comes on for "idle above expected value" instantly. And the oxygen sensor codes and neutral control switch low input only show with the car in test mode...I did notice my vaccum is weak. Between 10-14 at idle. And I noticed that the part of the inlet to the turbo is very very pliable and I can see little tears around where the hose clamp is and it looks like the inlet is expanded more than it should be.
    2002 WRB WRX
    Bugeye Mafia #335
    High Mileage Club 106K

    My Pics

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •