Loss of compression?
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on Loss of compression? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi all, I own a 2003 WRX and have recently noticed a reduction in power and what appears to be ...

  1. #1
    Registered User
    Join Date
    Sep 2008
    Location
    North Carolina
    Posts
    4

    Loss of compression?

    Hi all,

    I own a 2003 WRX and have recently noticed a reduction in power and what appears to be a loss (but not a total loss) of compression. My turbo gauge is just not moving under load the way it use to.

    I have a UTEC TurboXS racing ECU, and a laptop mounted in the car. When I test drive it, the UTEC reports back my max compression after every pull. the laptop consistently shows an average of 13 - 14 pounds of boost.

    the car idles fine, sounds fine, and otherwise runs great. Only 34k miles. Any ideas how to troubleshoot or things to look out for? could it simply be time for new spark plugs?

    Other mods to the car:

    Borla Header, cat-less up/down pipes, borla mid-back axhaust, cold air intake, bigger BOV, and the UTEC TurboXS ECU

    any advice would be appreciated...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Well the only real way to tell if you lost compression is a compression test, but before you go and do that there are loads of more questions...

    1. Any check engine light codes?

    2.Are you hitting target boost outlined in your MAP notes?

    3.What map are you useing and what mods are listed in the notes to use THAT map?

    4.Do Your current mods match exactly what mods are listed in the MAP notes?

    5.Things like your CAI and BOV have been known to mess up your A/F scaling and you could be running rich or lean both are bad for your car...

    6.Headers on these cars are pretty much pointless, unless your highly modified...

    7.Are there anyother symptoms other then It feels slower, or your "average boost" is only 13-14?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •