Turbo Problems
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Turbo Problems within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I was driving my 03 WRX the other day at about 70 mph, not pushing it much at all and ...

  1. #1
    Registered User
    Join Date
    Mar 2011
    Posts
    4

    Turbo Problems

    I was driving my 03 WRX the other day at about 70 mph, not pushing it much at all and all the sudden I notice my turbo is not spooling. I hear a kind of groaning sound in place of the sound of the turbo. I checked my oil, which was a little low, hoping that would fix the problem but still the same noise with no spool. The car still runs and idles fine. Where should I start? Any help would be greatly appreciated.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,021
    Look for a broken vacuum line. Probably have a leak somewhere. What oil are you using?
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  4. #3
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Check all of the intake tract as well as the vacuum lines that were already suggested.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #4
    Registered User batorr's Avatar
    Join Date
    May 2011
    Location
    Rochester, New Hampshire, United States
    Posts
    62
    the up pipes on that year wrx i believe have a cat on them and the up pipes with cats have been know to foul up the turbo when peices of the cat break off and get jamed into the turbo. i would check the lines first but if the turbo is making a noise i would have it checked out.

  6. #5
    Registered User Findus11's Avatar
    Join Date
    Nov 2007
    Location
    Ketchum, Idaho
    Posts
    670
    make sure your wastegate is still connected to the back of the turbo... my little clamp popped off once causing the wastegate to hang open and the car made no boost.
    Hawk Eye #1991
    Dirty Crew #11
    Military Militia #1991
    I still don't know how I got this car...

  7. #6
    Registered User
    Join Date
    Mar 2011
    Posts
    4
    i check all the vaccum lines they're all good but the turbo makes a groaning noise but i took the waste gate off and opened it and the groaning noise went away but it still wont build boost any other things it could be please let me know thank you

  8. #7
    Registered User batorr's Avatar
    Join Date
    May 2011
    Location
    Rochester, New Hampshire, United States
    Posts
    62
    have you taken the turbo off and looked at it for damage?

  9. #8
    Registered User
    Join Date
    Mar 2011
    Posts
    4
    I took the turbo off the fins spin freely and is fine. What should I check next while I have the turbo off?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •