power loss.....
Results 1 to 2 of 2

This is a discussion on power loss..... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; driving back home down the interstate last night.....and between 1/4 -3/4 throttle it sounded like i lost a cylinder and ...

  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    6

    power loss.....

    driving back home down the interstate last night.....and between 1/4 -3/4 throttle it sounded like i lost a cylinder and power wasnt there....boost was still building though......0-1/4 throttle no problems and 3/4 - full throttle no problem..........today was doing the same thing but had no combustion from 3/4 -full throttle and if i held the pedal down long enough i got a huge backfire........but sometimes it will run perfect.......any ideas?....maybe tps?

    2006 wrx
    ej257
    cp forged pistons
    delta utec
    18g turbo
    perrin front mount intercooler
    850cc injectors
    3" downpipe and exhaust
    cobb short ram intake
    Last edited by tallduade19; 05-12-2011 at 05:57 PM. Reason: add car info

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Feb 2011
    Location
    St Louis Park MN
    Posts
    3
    I am having the same problem with my 04 WRX. What did you do to fix it. thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •