Someone help!
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on Someone help! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; As I driving home from werk last night my intercooler top mount disconnected from i drove it home and conected ...

  1. #1
    Registered User JazzyMack's Avatar
    Join Date
    Mar 2011
    Posts
    33

    Someone help!

    As I driving home from werk last night my intercooler top mount disconnected from i drove it home and conected it back and now it's not boosting at all? Idk why

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,972
    I Support ClubWRX
    Sorry I don't understand what you're saying, please clarify.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User JazzyMack's Avatar
    Join Date
    Mar 2011
    Posts
    33
    My intercooler disconnected while I was driving home last night and when I got home I connected the intercooler back and my car anit boosting now

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,972
    I Support ClubWRX
    Check for more leaks in boost and vacuum lines.

    If it is actually not boosting at all, as in, zero pressure above atmosphere, check the C-clip on the wastegate arm also. I find it unlikely you had both failures at once though.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,862
    I Support ClubWRX
    At all? Are you sure the turbo/IC hose is properly seated?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  7. #6
    Registered User JazzyMack's Avatar
    Join Date
    Mar 2011
    Posts
    33
    With my luck I could have both failures.. Ima check it out do u think i could of blown my turbo

  8. #7
    Registered User JazzyMack's Avatar
    Join Date
    Mar 2011
    Posts
    33
    Quote Originally Posted by EJ257 View Post
    At all? Are you sure the turbo/IC hose is properly seated?
    Yea not boosting at all makes a noise like it wants to boost but doesnt at all

  9. #8
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    There's no reason to think you blew your turbo because of your intercooler coming off. Why did it come off? Was it just a hose or two that came disconnected, or did the whole thing actually come off its mounts/bolts?

    No boost to me says there's something still leaking. Pending answers to the questions above, I'd just go through and check all hoses/hose clamps and connections.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  10. #9
    Registered User JazzyMack's Avatar
    Join Date
    Mar 2011
    Posts
    33
    Quote Originally Posted by teflon_jones View Post
    There's no reason to think you blew your turbo because of your intercooler coming off. Why did it come off? Was it just a hose or two that came disconnected, or did the whole thing actually come off its mounts/bolts?

    No boost to me says there's something still leaking. Pending answers to the questions above, I'd just go through and check all hoses/hose clamps and connections.
    I checked everything and looks like my cupling is messed up and every time I go to boost it pops off in the front

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •