06 WRX stalled on me...wont start..any ideas?
Results 1 to 5 of 5

This is a discussion on 06 WRX stalled on me...wont start..any ideas? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, I'm kickin myself in the ass for not postin here sooner, I'd def get more info than my ...

  1. #1
    Registered User
    Join Date
    Mar 2011
    Posts
    3

    06 WRX stalled on me...wont start..any ideas?

    Hey guys, I'm kickin myself in the ass for not postin here sooner, I'd def get more info than my mechanic but here's what happened. Monday night, I stopped at a stop sign by my boys house, and when i turned left, the car stalled on me from the 1st to 2nd shift. Wouldn't start again...oddly enough, after 3 or 4 seconds of cranking, it sounds like it got a few drops of fuel and tried to start but wouldn't catch. 20 mins later, it managed to start and run for about 20 seconds only with help from me pressing on the gas.

    Because it was midnight, i figured to tow it to meineke which was two blocks away for the time being...so three days later, he can't figure it out, and he's calling in a subaru/mitsubishi specialist....the wrx has 80k on it, and hasn't rly been mantained at all cept for oil changes I told him to check the fuel pump seein as that's what I think it is but... ??

    Anyone had anything like this happen?

    i'd really appreciate any help,

    Thanks,
    Shawn

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    IAC valve? Massive vacuum leak? Are there any codes stored in the ECU? Could be a lot of different things, hard to tell
    Stink eye mob #727
    2011 WRX DGM Hatch, Protuned Stage 1

  4. #3
    Registered User
    Join Date
    Mar 2011
    Posts
    3
    hey man, yeah coincidentaly, i already have a check engine light on, with the cruise light flashing also. I've had that issue for a few yrs never got it looked at. But, I'm assuming he would know to check vacuum and idling components. Sucks, thanks again mang.

  5. #4
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,642
    I Support ClubWRX
    Quote Originally Posted by shawn744
    hey man, yeah coincidentaly, i already have a check engine light on, with the cruise light flashing also. I've had that issue for a few yrs never got it looked at.
    Why would you not look at what the CEL was for?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  6. #5
    Registered User WillieRX's Avatar
    Join Date
    Nov 2010
    Location
    CO Mountains
    Posts
    302
    CEL for several years?!?! Well, sounds like you were slowly killing your engine during that time frame. I would suggest pulling the codes and going from there.
    2006 Subaru WRX TR (Weekend Warrior)
    1993 Ford F250 Diesel (Daily Work Commuter)
    Hawk-Eye Alliance #9455
    My WRX Mods

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •