Engine issue with my 2010 WRX
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Engine issue with my 2010 WRX within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys i am having an issue with my car all of a sudden. When i go full throttle and ...

  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    42

    Engine issue with my 2010 WRX

    Hey guys i am having an issue with my car all of a sudden. When i go full throttle and hold it, the boost goes to 15 PSI and then a hissing noise happens and i loose pressure. it only happens when i give WOT. I am sure its normal but i have never heard this noise before. The only mods i have on my car is a boost gauge.

    Any thoughts thanks guys?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Check the charge pipe from the turbo to intercooler, the pipe from the intercooler to throttle body, check around the end tanks, and BPV as well. Sounds like a boost leak, likely just a loose clamp. I'm assuming you're not hearing the BPV when you lift the throttle (OEM one shouldn't be that loud).
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  4. #3
    Registered User
    Join Date
    Nov 2010
    Posts
    42
    no i was about to say it seems like the opposite of a blow off valve because it happens when i hammer thr throttle and don't let go. Is there anyway to test for a leak when the car is at idle?

  5. #4
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Not really, unless it's a really massive leak. You can however pressure test your intake tract, no link handy, but there should be a thread on here. I'd start with the clamps on the pipes leading into, and out of the IC, also visually inspect for cracks, etc... Also see if the BPV bolts are tight.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •