Turbo Issues.. Please Help
Results 1 to 9 of 9

This is a discussion on Turbo Issues.. Please Help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a 2002 WRX with a lot of aftermarket modifications. For the last couple of months my Turbo fades ...

  1. #1
    Registered User stiluk35's Avatar
    Join Date
    Mar 2010
    Location
    Altoona PA
    Posts
    9

    Turbo Issues.. Please Help

    I have a 2002 WRX with a lot of aftermarket modifications. For the last couple of months my Turbo fades in and out when I'm really on it.. When I move quickly through the gears I have no problems but when Im pushing the turbo in 4th or 5th gear thats when the issue is very apparent. I put on a new fuel filter hoping that would help (cheapest solutions) and it didn't help much. I don't know if I need new fuel injectors or a new turbo? Someone also mentioned to me something about the pressure valve being plugged up.

    I would appreciate some feedback if anyone has experienced something similar..

    Thanks,
    Luke

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,616
    I Support ClubWRX
    I don't understand what "fades in and out" actually means.

    Is boost constant? Can you post logs? What are the actual symptoms? Do the revs climb but the car fails to accelerate?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User stiluk35's Avatar
    Join Date
    Mar 2010
    Location
    Altoona PA
    Posts
    9
    Well when looking at the boost gauge the tac rises and drops when it should hold steady... more importantly you can feel the car not getting the boost.. It has boost for about 3 seconds and then cuts out for about 3 seconds... in a smooth transition between... Its clearly a fuel issue... im just not sure what the specific problem is.

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,616
    I Support ClubWRX
    Sounds like your boost is fluctuating?
    http://www.clubwrx.net/forums/search...earchid=222909
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Registered User stiluk35's Avatar
    Join Date
    Mar 2010
    Location
    Altoona PA
    Posts
    9
    Yes that sounds like an accurate description of my problem... any idea on what is causing it? Thanks for your help.

  7. #6
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,616
    I Support ClubWRX
    Have a look at the link in my previous reply. There could be several causes.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  8. #7
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,111
    I Support ClubWRX
    Last edited by Donkey; 03-03-2011 at 04:29 PM.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  9. #8
    Registered User stiluk35's Avatar
    Join Date
    Mar 2010
    Location
    Altoona PA
    Posts
    9
    Definetely not the clutch.. I have driven cars with bad clutches.. plus I replaced it when I bought the car which was about 15k miles ago. There is no slipping just loss of power.

  10. #9
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,111
    I Support ClubWRX
    Quote Originally Posted by stiluk35 View Post
    Definetely not the clutch.. I have driven cars with bad clutches.. plus I replaced it when I bought the car which was about 15k miles ago. There is no slipping just loss of power.
    You caught me before my edit. I saw you mention "tach" as in tachometer which is the RPM gauge on the car,not boost.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •