Rattling grind noise
Results 1 to 7 of 7

This is a discussion on Rattling grind noise within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Here's the problem, when driving in any gear from 2500 rpm to 3000 rpm i hear a grinding noise coming ...

  1. #1
    Registered User
    Join Date
    Jan 2011
    Posts
    26

    Rattling grind noise

    Here's the problem, when driving in any gear from 2500 rpm to 3000 rpm i hear a grinding noise coming from the engine area. It happens when i give it 50 percent throttle or more. its not too loud but its annoying.
    the cars a 09 wrx with 29000 miles on it. all stock.
    i took it to the dealer and they couldnt reproduce the noise so i have to bring it in another time when i can give on of their techs a ride.
    i know itll be covered under warrenty but im just wondering what it is if any of you know.


    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Does it vary with road speed? What about with engine speed? Does it happen more or less in any gear? Uphill or downhill? While straight, turning, or always? Need more info.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User
    Join Date
    Jan 2011
    Posts
    26
    Same in every gear 2500 to 3000 rpm under hard acceleration this noise appears and goes away after 3000 rpm doesn't matter speed, uphill or dOwnhill. Just the rpms

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    I had a customer complaint of this problem on their 2009 WRX, ended up replacing the turbo, and the problem was cured. You mentioned it only happens under hard boost?

  6. #5
    Registered User
    Join Date
    Jan 2011
    Posts
    26
    Yeah it's only under hard acceleration. It almost sounds like it could be from the turbo. I'll bring this to the dealers attention thanks

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    no problem man, only have done one of them under warranty like this, I would be curious to hear the outcome of your problem...

  8. #7
    Registered User
    Join Date
    Jan 2011
    Posts
    26
    I'll deff let you know then. Whenever I get the time to go in again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •