Possible bad knock and throttle position sensor or wastegate actuator?
Results 1 to 6 of 6

This is a discussion on Possible bad knock and throttle position sensor or wastegate actuator? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So on my 96 sti wrx when I get on the gas pedal there are times where I'll hit higher ...

  1. #1
    Registered User
    Join Date
    Jan 2011
    Location
    JAPAN
    Posts
    12

    Possible bad knock and throttle position sensor or wastegate actuator?

    So on my 96 sti wrx when I get on the gas pedal there are times where I'll hit higher boost and the engine will bog and flutter and the boost gauge goes crazy I've been looking around and trying to fnd the problem. Has anyone else had this proble. I just dont want to replace the sensors an it be the actuator and vice versa

    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    What mods does the car have? Mileage? How long has this been happening?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User
    Join Date
    Jan 2011
    Location
    JAPAN
    Posts
    12
    It has hks cold Air intake, 3 inch Downpiping/hks exhaust. It's got 65000 miles on it. It's been happening for the past week I believe it's just the sensors but I'm just trying to reduce the pain of replacing wrong parts you know

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,970
    I Support ClubWRX
    Then test the parts.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User
    Join Date
    Jan 2011
    Location
    JAPAN
    Posts
    12
    Sure enuf it was the parts plus ****ty on base American gas so what's everyone take on octane boosters?

  7. #6
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,578
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by my96sti View Post
    Sure enuf it was the parts plus ****ty on base American gas so what's everyone take on octane boosters?
    Octane boosters are crap IMO. If you want the motor to run properly, get tuned for 93 Octane fuel. You'll save yourself the headache.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •