04' STI, need help ASAP.
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 04' STI, need help ASAP. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'll try to explain this with as much details as possible since I do not have any photos or video. ...

  1. #1
    Registered User
    Join Date
    Jan 2011
    Posts
    36

    04' STI, need help ASAP.

    I'll try to explain this with as much details as possible since I do not have any photos or video. 04'STI, 148k miles stock.

    Well, this has happened a few times but has not occurred in a while so I assumed it was fixed. Yesterday after turning off the car and heading to BK, when I got my order I left. When I turned on the car it began to shake and then I noticed smoke coming from the right side of the engine bay. I immediately turned off the car and back on again, same thing. So I decided to wait a while and then it went back to normal, I still drove home very carefully.


    ** This happens basically within the same time frame 5min; turn car off, leave for a few minutes, turn back on -- then noticeable shaking starts with smoke coming from engine bay.**

    I just really need to know what this is before it gets worse, also can it be that my brother accidentally put 89 octane gas instead of 93 a few weeks ago (I quickly changed the gas, since I noticed knocking noise meaning he put wrong gas, which thankfully the noise is slowly reducing).

    EDIT -- I found a video of how my idle was everytime this happens, only thing is the car in the video is a WRX. I was looking for another one but with a STI, no success.



    Thanks everyone for the help
    Last edited by DoloSoLow; 01-30-2011 at 12:36 PM. Reason: Found a video source

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Let's start with what mods the car has. Is it stock?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User
    Join Date
    Jan 2011
    Posts
    36
    Yes, its completely stock.

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,318
    I Support ClubWRX
    Well if it doesn't have a CEL then it could be alot of things. Maybe it just needs new sparkplugs or the MAF cleaned. Check to see if anything is loose/cracked on vacuum hoses and intake track. Clean and retorque the engine grounds and battery terminals. With any substantial data its kinda hard to diagnose of the internet.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •