power steering problems
Results 1 to 4 of 4

This is a discussion on power steering problems within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok i just replaced my power steering pump on my 05 wrx, i flushed all the old fluid out and ...

  1. #1
    Registered User
    Join Date
    Feb 2008
    Location
    RENO, NEVADA
    Posts
    26

    power steering problems

    ok i just replaced my power steering pump on my 05 wrx, i flushed all the old fluid out and replaced it with new fluid. It had some air it and the fluid was aerated and foamy. i got out all the air the fluid is now clear but when i'm driving the power steering is loose then during a turn it will stiffen up like it doesnt have power steering and then it will loosen back up. I'm at a loss and don't know what to do.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User MakeItRoar's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Illinois
    Posts
    321
    Pulley is being underdriven or overdriven? Did you put the belt at the correct tension, and get the same pulley size? How did you blow the pump in the first place? If you have a slight leak, that would account for a few problems.
    2006 WRX Limited -Pro-tuned VF-39, STI TMIC, STI factory I/C Sprayer, Throttle body Coolant Bypass, STI Exhaust, SPT Short Ram Intake, SPT Upper Front and Rear Strut Bar, Red Samco Radiator Hoses, STI Trunk, SPT Short Shifter, Aftermarket Rotors, Lamco Turbo Gauge, Catless Downpipe, Hella Supertones, RallyArmor Limited Edition Pink UR Flaps, 35% Tint, Grounding Mod, Walbro 255 Fuel Pump, SPT Heat Shield STI Piston Shift Knob!
    Hawk-Eye Alliance #430

  4. #3
    Registered User
    Join Date
    Feb 2008
    Location
    RENO, NEVADA
    Posts
    26
    The pump went do to a faulty hose clamp and leaked the fluid out. The stock hose clamp is a pinch clamp so I replaced it with a standard screw clamp. I had the pump rebuilt cause the stealership wanted $700 for a new one. I kept the same pulley and reused it. The tension on the belt is good. So I dont know if I didn't get all the air out or what?

  5. #4
    Registered User
    Join Date
    Oct 2013
    Posts
    3
    I know this is a little late, but you may be able to help me. I have a VERY similar problem. Power steering went out, I am unsure of why it went out the first time. I replaced the pump and put in new fluid all that fun stuff. Regardless, about 10 minutes after I replaced the pump it started to stiffen and then only proceed to work above 3000 RPM, but not if its idle, has to be moving and above 3000.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •