Possible rod KnocK ?????? plz help ASAP.
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Possible rod KnocK ?????? plz help ASAP. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Well, ever since I figured out that the correct type of gas for my 04' WRX was octane 93 thats ...

  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    55

    Possible rod KnocK ?????? plz help ASAP.

    Well, ever since I figured out that the correct type of gas for my 04' WRX was octane 93 thats all I have been putting, ran good except for hard to turn on due to low charged battery(fixed).
    Unfortunately, yesterday my father borrowed the car and today the car has been acting very weird......

    * Weird click noise after releasing the throttle petal(rev).

    * When warm, the car started to shake (I felt it -_-) all while smoke was coming out from hood scoop.

    All I would like to know if the gas that my father put caused this or just a coincidence. Also if that weird noise a rod Knock.

    INFO___

    04' WRX 145k miles Stock.
    History of P0304, still trying to fix- Next attempt replace o2 Sensors.

    Thanks in advance for everyone that has helped, seriously.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Nov 2010
    Location
    Columbus, Ohio, United States
    Posts
    76
    Sounds like your dad either drove the car way to hard n blew it. is that the case? or did he put gas it? not wasn't 93?

  4. #3
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    What gas were you putting in it before the 93 and for how long?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  5. #4
    Registered User
    Join Date
    Oct 2010
    Posts
    55
    Quote Originally Posted by vr4drivin View Post
    Sounds like your dad either drove the car way to hard n blew it. is that the case? or did he put gas it? not wasn't 93?
    Trust me... my father is not the hard driving type of guy, seriously. BTW he used it to go to work since I needed his car to help my sister move to her campus.

    Quote Originally Posted by teflon_jones View Post
    What gas were you putting in it before the 93 and for how long?
    The car when first purchased(sep2010) we accidentally put in octane 87(regular, for one day) and quickly changed it to octane 89(premium) -- Both having the same symptoms I described.

    Nonetheless I figure out (by clubwrx & nasioc) I was originally suppose to use octane 93(used since Sept until yesterday), and what do you know it worked, no more weird noise or any other issues stated.

    So any idea what caused this??

  6. #5
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    So it has worked fine since you've run 93 then?

    It can and most likely will knock with a lower octane if you run it that long because the ignition is being retarded due to the lower octane fuel, which the engine isn't designed for. Count yourself lucky if you didn't cause permanent damage and it's running fine now. Never again put in lower than 91.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  7. #6
    Registered User
    Join Date
    Oct 2010
    Posts
    55
    ooo ok, but yea basically no problems at all when I use 93 excluding the misfire code(p0304)which I'm in the process of fixing - Replacing the 02 sensors.

    Thanks for everything, seriously. FYI I still have not put 93 yet I just stop driving the car until I figured out what is causing this, so tomorrow I'll put 93 since its almost empty. *hoping for the best, I'll update this thread tomorrow after a quick drive btw*

  8. #7
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    o2 sensor is a likely reason for the p0304 code. Pay attention to the label on the fuel door of your car in the future that says "premium fuel only." They put it there for a reason.

    Glad to help educate
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  9. #8
    Registered User
    Join Date
    Oct 2010
    Posts
    55
    ooo lol. .... FYI someplaces here in NJ premium is 87, which my father always says. I on the other hand tend to say "93 (amount$) cash". Either way thanks again for everything

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •