URGENT! HELP PLEASE
Results 1 to 3 of 3

This is a discussion on URGENT! HELP PLEASE within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am on my way to pick up my wife who has a 02 WRX 55K miles approx. She was ...

  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    49

    URGENT! HELP PLEASE

    I am on my way to pick up my wife who has a 02 WRX 55K miles approx. She was leaving from work and the car wont turn on, she messed with the battery cable and it came on, but she turned it off by taking the key out and the car kept running! Weird. Also the dash lights come on and when she tries to crank it, it cranks but wont start.... whats the deal here?!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User MakeItRoar's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Illinois
    Posts
    321
    Grounding got messed up? I can't think of anything else that links all those together.
    Last edited by MakeItRoar; 01-13-2011 at 03:58 PM.
    2006 WRX Limited -Pro-tuned VF-39, STI TMIC, STI factory I/C Sprayer, Throttle body Coolant Bypass, STI Exhaust, SPT Short Ram Intake, SPT Upper Front and Rear Strut Bar, Red Samco Radiator Hoses, STI Trunk, SPT Short Shifter, Aftermarket Rotors, Lamco Turbo Gauge, Catless Downpipe, Hella Supertones, RallyArmor Limited Edition Pink UR Flaps, 35% Tint, Grounding Mod, Walbro 255 Fuel Pump, SPT Heat Shield STI Piston Shift Knob!
    Hawk-Eye Alliance #430

  4. #3
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,487
    I agree with MakeItRoar, make sure the cables going to the battery are secure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •