p0304... still stumped, possabile piston ring issue?
+ Reply to Thread
Results 1 to 14 of 14

This is a discussion on p0304... still stumped, possabile piston ring issue? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; okay, so... I've had this misfire issue and I have done the following to diagnos it... 1.cleaned MAF sensor 2.replaced ...

  1. #1
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606

    p0304... still stumped, possabile piston ring issue?

    okay, so... I've had this misfire issue and I have done the following to diagnos it...
    1.cleaned MAF sensor
    2.replaced the spark plug
    3.swapped around the coil packs
    3.did a compression test (when cold) and readings were 120,120,110,120
    4.tested the ground connections
    5.ran a new ground wire to that cylinder
    6.took it to a dealer to check it out (it was close to closing on the weekend and they said the injector sounded okay)
    7.I've done datalogging and everything seemed normal made a few adjustments

    So... with that being said, I called a local shop here (they specialize in subarus) and they told me that it's most likeley a piston ring issue... They told me that they've got a few in with simular issues and they did compression tests on them and have came back normal, plus then they tear down the engine and find burned up piston rings... They said it would be $1800 to rebuild it... So... I'm at a loss at the moment and I just can't see if it were a ring issue that wouldn't show up on a compression test... Please help, I'm about ready to put my head through a wall...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    I agree with you, a bad ring should show up on a compression test. Did you do a wet and dry test? could be a valve issue, could be a vacuum leak. Can't really think of anything else it could possibly be. The dealer said the injector sounded OK? You could try swapping injectors to be sure. Let us know what you come up with

  4. #3
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    It was a dry compression test and I'm sure a bad valve would've shown up as well cause the valves work as the motor turns.. It could be a vacuum leak somewhere but there is so much to check its retarded... I'll keep everyone posted, I hope the guy was just jerking me around about that, cause the car only has 61K on it and it is virtually stock other then a retune and cbe...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  5. #4
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    A leak down test should point you in the right direction.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  6. #5
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    What all does a leakdown test show? To my understanding I thought it just showed if the head gasket had a good seal...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  7. #6
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Quote Originally Posted by 06scoobyrex View Post
    What all does a leakdown test show? To my understanding I thought it just showed if the head gasket had a good seal...
    It will pinpoint the source of the leak.

    The neat thing about a leakage test (as opposed to a compression test) is that it's faster and easier to figure out where the pressure is going. If you hear air coming out of the tailpipe, it indicates a leaky exhaust valve. Air coming out of the throttle body or carburetor would point to a leaky intake valve. Air coming out of the breather vent or PCV valve fitting would tell you the rings and/or cylinders are worn.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  8. #7
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Allright thanks man... do you know how mutch a shop would charge to do one?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  9. #8
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Not sure; I paid ~$120 IIRC at a performance shop; I think the dealership bends you over on a comp/leak down test as they're mandated to do both at the same time from what I hear.

    Good luck.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  10. #9
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    We charge an hour labor but, of course, there's no standard. It'll vary from shop to shop, I would call around

  11. #10
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Okay thanks guys... I did find this thread about ringland symptoms and I think the 2nd or 3rd post down showed a drop of 50psi on the cylinder with the ring issue... I know it varies from car to car, but the guy at the shop told me there could be an issue with as little as 10psi difference.... I just think there would be a larger difference then 10psi if it were a ring issue... all of my cylinders read 120 and cylinder 2 showed 110, yet the 4th cylinder is the 1 with the issue...
    here is a link to that thread I did read that...
    What are the symptoms of a cracked piston ring? - Subaru Impreza WRX STI Forums: IWSTI.com
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  12. #11
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    General rule I use is less than 15% variation is OK so 10 psi with your numbers is usually acceptable and I wouldn't think cause a misfire code

  13. #12
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Yeah... that guy at the shop I talked to said he's seen ring problems with as little as 10psi difference, so I think there would be a larger difference in the pressure...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  14. #13
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,241
    I Support ClubWRX
    You didn't try everything. Swap injectors to see if the problem moves and do a combustion chamber cleaning. Also run some injector cleaner through a couple of tanks. Also the valve clearances need to be checked.

    IF YOU HAVE A MISFIRE CODE ,PLEASE READ THIS!!!
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  15. #14
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    At thithis point I'm most likely going to take it into the dealership... I've tried as much as I can to my mechanical ability so I'm sure they will find it easier and save more money in the long run then just checking different things that might not even correct the problem...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •