Newb to WRX and turbos, Need Help
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Newb to WRX and turbos, Need Help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello, well I may or may not have done something stupid. I am into lifted/offroad vehicles and this is all ...

  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    2

    Newb to WRX and turbos, Need Help

    Hello, well I may or may not have done something stupid. I am into lifted/offroad vehicles and this is all I really know. I randomly traded one of my three lifted trucks in order to try something different. I ended up with a 02 WRX with 130,000. I don't know anything about these cars and have done some searching on the site and have confused myself a little more. From what the previous owner told me and from what I have seen, it has a AEM boost controller and (i think) 2.5" straight pipe exhaust that are both new within 6 months. I have read good and bad about the boost controller. It has at least one code thrown, I am out of town right now or I would have it checked. It is idling very low, and has died a couple times when I am coming to a stop and push the clutch in. He said he needed to get it tuned after the boost and exhaust and never did. I am wondering if this is true and also what the boost controller should be set at for everyday driving. Any help on the problem would be appreciated. I will also get the code run when I get home.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    The boost controller should be set to whatever the car is tuned for. From my signature, you can see I'm experienced in your world too. Straight pipe meaning no muffler, cats, etc? Just straight through 2.5" tubing?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User
    Join Date
    Dec 2010
    Posts
    2
    I will have to look at the pipe when I get back in town. So could having the boost set to anything but the stock setting cause the idle issue I am having?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •