engine problem???
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

This is a discussion on engine problem??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi i have a 03 wrx and my car has been acting weird ill be driving and the car will ...

  1. #1
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48

    engine problem???

    hi i have a 03 wrx and my car has been acting weird ill be driving and the car will stall all of a sudden? why might this happen? and when im parked ill rev it up some and when i let go of the gas the rpms drop really low to like 500 and goes back to 1200rpms and shakes like it wants to turn off, im thinking it an electrical problem but can you guys help me out? thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User lytlec's Avatar
    Join Date
    Jan 2009
    Location
    Central PA
    Posts
    4,268
    Gonna have to tell us if you have any mods.
    <-------- Taylor Swift.
    2006 WRX 330whp. 300wtq. Slow.
    Hawk-Eye Alliance #137
    First Mods...what to do.
    Subaru Guide

  4. #3
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by lytlec View Post
    Gonna have to tell us if you have any mods.
    i have a full exhaust system and reflashed to stage 2, and when i bought the car it already had a turbo xs bov

  5. #4
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Any check engine codes setting off the light? And if so post them...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  6. #5
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    it doesnt have a check engine light on

  7. #6
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,754
    Just because the CEL isn't on doesn't mean there are no codes. Do you have access to an OBDII reader?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  8. #7
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by teflon_jones View Post
    Just because the CEL isn't on doesn't mean there are no codes. Do you have access to an OBDII reader?
    okay i didnt know that and i dont have access to an OBDII reader can autozone check it or where can i get it checked

  9. #8
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,754
    Yes autozone or any store like that can check it for you.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  10. #9
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by teflon_jones View Post
    Yes autozone or any store like that can check it for you.
    okay i will go check and i toke a video of my car doing it ill be uploading soon

  11. #10
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    okay i went to autozone today and got them to check the check engine and it didnt have no codes... and i uploaded a video i toke of my car acting weird as you can see in the video after i let go of the gas and the rpms go down all the way and the rpms jump and the car shakes like it want to stall..
    heres the video..
    YouTube - Troubleshooting

  12. #11
    Registered User MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,564
    I Support ClubWRX
    Are you sure it still has the factory flywheel? Lightened flywheel can cause what you're talking about.

  13. #12
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    First thing I would recommend is a cleaning of your IACV and replacement of its gasket. It's the most common cause of idling issues associated with 02-05 WRX's.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  14. #13
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by MainFrame View Post
    Are you sure it still has the factory flywheel? Lightened flywheel can cause what you're talking about.
    im not sure about the flywheel i have only had the car for a year and so i shouldnt get a lighter flywheel? because im get my transmission rebuild with lgt gears and i was going to change the clutch and flywheel while the transmission was off

  15. #14
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by Anub1s View Post
    First thing I would recommend is a cleaning of your IACV and replacement of its gasket. It's the most common cause of idling issues associated with 02-05 WRX's.
    Okay im going to get the IACV cleaned as soon as possible and after that most likely the car should stop stalling while im driving and when im parked?

  16. #15
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by jaap View Post
    Okay im going to get the IACV cleaned as soon as possible and after that most likely the car should stop stalling while im driving and when im parked?
    It's no guarantee, but like I said, it's the most common cause of idle problems. It's where my money lies, but if it doesn't clear up the issue, then we can go into other troubleshooting methods.

    Make sure whoever does the cleaning for you replaces the gasket. The gasket can not be reused.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •