engine problem??? - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 26 of 26

This is a discussion on engine problem??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Okay thanks I will be trying that and hopefully it's that...

  1. #16
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Okay thanks I will be trying that and hopefully it's that

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Here's to hoping. Keep us updated.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #18
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Hey guys so today I did the diy for cleaning the iacv and after it idled a lot better the sensor was so dirty I have pictures of them, but I still have the problem with my car stalling and I have noticed it usually stalls when going fast and than trying to stop

  5. #19
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by Anub1s View Post
    Here's to hoping. Keep us updated.
    hey so i did what you told me to clean the iacv and i have been getting a lot of white smoke but i cant tell if its because it has a leak or because its cold and if i reopen the iacv agian would i have to replace that new gasket with a new one?

  6. #20
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by jaap View Post
    hey so i did what you told me to clean the iacv and i have been getting a lot of white smoke but i cant tell if its because it has a leak or because its cold and if i reopen the iacv agian would i have to replace that new gasket with a new one?
    How much is a lot, and where is the white smoke coming from? If it's in the engine bay, then yes you probably have a leak at the IACV, either a bad gasket, or from not torquing it down correctly. These things happen, nothing to be upset about, but yea I would definitely recommend a new gasket, just to rule out the factor of maybe having recieved one that may have been malformed or sat around for too long. Rubber gaskets are something one should never reuse.

    I'm glad it's idling better, that's a sign that it needed to be done anyways, but sadly it didn't fix your issue. I would look up the steps to DIY MAF cleaning and go that route as well. These are things that can be done quickly and don't cost a lot of money and are often causes to many a problem, so it's good to rule these things out first.

    After cleaning the MAF, I would recommend you reset the ECU, there are also steps for that here as well.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  7. #21
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by Anub1s View Post
    How much is a lot, and where is the white smoke coming from? If it's in the engine bay, then yes you probably have a leak at the IACV, either a bad gasket, or from not torquing it down correctly. These things happen, nothing to be upset about, but yea I would definitely recommend a new gasket, just to rule out the factor of maybe having recieved one that may have been malformed or sat around for too long. Rubber gaskets are something one should never reuse.

    I'm glad it's idling better, that's a sign that it needed to be done anyways, but sadly it didn't fix your issue. I would look up the steps to DIY MAF cleaning and go that route as well. These are things that can be done quickly and don't cost a lot of money and are often causes to many a problem, so it's good to rule these things out first.

    After cleaning the MAF, I would recommend you reset the ECU, there are also steps for that here as well.
    okay the smoke is coming out from the exhaust and some from the engine but i think my car has a bad uppipe gasket and i didnt torque the bolts, how would i torque them i replaced them with hex screws? and since i didnt torque them am i going to replace the gasket with a new one?

  8. #22
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    What do you mean you replaced the bolts with hex screws?

    If it's leaking, then I'd replace the gasket when you re-torque. And you need to torque it again after driving it a few days.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  9. #23
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Quote Originally Posted by teflon_jones View Post
    What do you mean you replaced the bolts with hex screws?

    If it's leaking, then I'd replace the gasket when you re-torque. And you need to torque it again after driving it a few days.
    This are the original screws and the hex screws, i am using scooterforever from nasioc diy and image


  10. #24
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,083
    I Support ClubWRX
    My guess is the BOV might be leaking.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  11. #25
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48
    Here's a video of my car with that smoke after it reached operating temp.. And I'm going to clean the maf sensor tomorrow and hopefully it will make the car run better and what would be the best way to check if my bov has a leak? Thanks

  12. #26
    Registered User jaap's Avatar
    Join Date
    Jul 2010
    Location
    Alabama
    Posts
    48

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •