Possible issues when low on fuel???
Results 1 to 7 of 7

This is a discussion on Possible issues when low on fuel??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok, so I've been getting the P0304 code on my 04' WRX for a while now, but I recently realized ...

  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    55

    Possible issues when low on fuel???

    Ok, so I've been getting the P0304 code on my 04' WRX for a while now, but I recently realized that the CEL light came off on its own after I filled up the gas. Nonetheless as soon as the car passes a little below the half way point on the gas indicator, the check engine comes back on. Maybe its just me, do you guys think this is the cause of the misfire (low on fuel).

    ** THINGS DONE **
    all spark plugs changed.
    2 coil packs changed (3 and 4).
    one bottle injector cleaner.
    Cleaned MAF.


    thanks guys.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    How many miles are on the vehicle? How many times has this actually happened ( fill up CEL goes off, get below half tank CEL comes on ) ? Is the car actually misfiring like do hear/feel it? Does the vehicle seem to miss when your off idle like driving around? Can you hit target boost and if you can does it hold target boost? I have a couple things Im thinking of however I dont want to throw red flags without getting some more information fore as you know diag. over the internet is rather difficult haha...

  4. #3
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Might want to do your fuel filter and give a little love to the pump sock and clean it off. There are times where they've been so clogged with gunk that people have had flow problems.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,752
    Quote Originally Posted by Anub1s View Post
    Might want to do your fuel filter and give a little love to the pump sock and clean it off. There are times where they've been so clogged with gunk that people have had flow problems.
    Yeah I agree, if it's happened a bunch of times, then I'd suspect the higher fuel level and resulting pressure is otherwise compensating for some problem with fuel getting to the engine. Most likely cause is a clog in the filter. Ever fill up when a tanker was filling the tanks?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Registered User
    Join Date
    Oct 2010
    Posts
    55
    Quote Originally Posted by EvoEatr View Post
    How many miles are on the vehicle? How many times has this actually happened ( fill up CEL goes off, get below half tank CEL comes on ) ? Is the car actually misfiring like do hear/feel it? Does the vehicle seem to miss when your off idle like driving around? Can you hit target boost and if you can does it hold target boost? I have a couple things Im thinking of however I dont want to throw red flags without getting some more information fore as you know diag. over the internet is rather difficult haha...
    Ok, to tell you the truth I've just realized this possibility now so I really don't know how many times this has occurred. As for when the vehicle misfires, its usually when I'm driving around at 50+mph (the idle acts unusual when changing gears).... btw the car has around 144k miles.


    Thanks again.

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by OutFittedWRX View Post
    Ok, to tell you the truth I've just realized this possibility now so I really don't know how many times this has occurred. As for when the vehicle misfires, its usually when I'm driving around at 50+mph (the idle acts unusual when changing gears).... btw the car has around 144k miles.


    Thanks again.
    How is your boost? does it hold target boost or does it seem to kind of surge or fluctuate a tad?

  8. #7
    Registered User
    Join Date
    Jun 2010
    Location
    New Jersey
    Posts
    118
    the boost holds target boost ..
    Pic to soon to come ...... 19 yrs old. Drive a Subbie( Im a newbie). 3rd Year Of college going to third.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •