question about cel
Results 1 to 5 of 5

This is a discussion on question about cel within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a couple of questions. First I have an 04 sti with stage 2 mods and a stage 2 ...

  1. #1
    Registered User 04stiman's Avatar
    Join Date
    Feb 2010
    Location
    Ocean Shores, Washington
    Posts
    165

    question about cel

    I have a couple of questions. First I have an 04 sti with stage 2 mods and a stage 2 tune from cobb accessport. I just installed a walbro 255 lph fuel pump and now my cel is on. I read the codes with my accessport and it said that my neutral switch circuit high was wrong. I was wondering why this was?

    I also have another question. Whenever I have a car full of people or a lot of items in my trunk whenever I turn to the left my right rear tire rubs and it is cutting into the sidewall of my tire. I do not have any lowering springs. If someone could help me out I would greatly appreciate it. Thanx

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,295
    I Support ClubWRX
    Did you happen to remove the I/C or mess around near the top of the gearbox? There's a harness clip there, maybe you nudged it?

    As for the rubbing, I see you are not using the Subaru wheels. Is your fitment and offset correct? Do you get a thunking in the back too? Are your dampers OK?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,678
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by SD_GR View Post
    As for the rubbing, I see you are not using the Subaru wheels. Is your fitment and offset correct? Do you get a thunking in the back too? Are your dampers OK?
    +1. As SD has suggested, please tell us what wheel dimensions you are running.

    i.e. 17x8 +48 offset
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by 04stiman View Post
    I have a couple of questions. First I have an 04 sti with stage 2 mods and a stage 2 tune from cobb accessport. I just installed a walbro 255 lph fuel pump and now my cel is on. I read the codes with my accessport and it said that my neutral switch circuit high was wrong. I was wondering why this was?

    I also have another question. Whenever I have a car full of people or a lot of items in my trunk whenever I turn to the left my right rear tire rubs and it is cutting into the sidewall of my tire. I do not have any lowering springs. If someone could help me out I would greatly appreciate it. Thanx

    I believe I have seen one neutral switch go bad on an sti, not like the numerous problems with older imprezas and such...anyways As mentioned check the connectors and wiring, I have had terminals back out of harness connectors before on these things...Also this might seem ridiculous however I feel I should mention it because believe it or not I have run into it...exactly how much stuff are you putting in the trunk/back seat? I just mention this because I have had people complain about issues like this before simply because they where overloading...

  6. #5
    Registered User 04stiman's Avatar
    Join Date
    Feb 2010
    Location
    Ocean Shores, Washington
    Posts
    165
    I mean I hear the noise when in my car there is me and two other passengers if they are both sitting on the right hand side. I also hear the noise if I have me and three other passengers in my car as well. Or if I only have 1 other person but have a couple suit cases in the back.
    Last edited by 04stiman; 11-29-2010 at 10:59 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •