HELpp im getting like 5 Mpg .. wthh =[
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 18

This is a discussion on HELpp im getting like 5 Mpg .. wthh =[ within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i am the proud owner of a wrx for about 3 days now =] for some reason my MPG Suckk. ...

  1. #1
    Registered User
    Join Date
    Nov 2010
    Location
    Richmond Hill, Queens, NY
    Posts
    44

    Post HELpp im getting like 5 Mpg .. wthh =[

    i am the proud owner of a wrx for about 3 days now =]

    for some reason my MPG Suckk. and im not expecting like 495898908 mpg

    i get 90 miles from full to Empty.. and i take my time ...wth

    please help me .............idk what could be wrong..

    2004 wrx 2.0 5spd 140k..

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Any mods to it or is it stock? Does it run fine other than the crappy gas mileage?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,311
    I Support ClubWRX
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  5. #4
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Please follow the guidelines in Donkey's link, and we'll be happy to help you figure out this problem ^_^

  6. #5
    Registered User
    Join Date
    Nov 2010
    Location
    Richmond Hill, Queens, NY
    Posts
    44
    the car is bone stock, no mods done at all

    everything is stock car still has 140k, i take my time driving
    new air filter,
    new oil change 5w40
    car drives smooth and perfect

    i still get bad mpg..
    im just confused on what i got myself into...
    thanks in advance

  7. #6
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,311
    I Support ClubWRX
    We are confused as well. I don't know how "drives smooth and perfect" and "gets 5 mpg's" go together ! Honestly can say have never seen somebody report 5 mpgs. If that is the case you car would not be running. In fact that much gasoline in the cylinders could easily cause bore wash,totally contaminating and breaking down your oil, and even possibly hydrolock at some point. So you get 5mpg's and not even a CEL? Maybe you have a hole in your gas tank.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  8. #7
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Did you change the oil your self? If so did the oil smell weird?
    Do you ever smell raw fuel after driving the car? Maybe it's leaking from the fuel rail, or somewhere else along the fuel lines.

  9. #8
    Registered User xFalleNx's Avatar
    Join Date
    Nov 2010
    Location
    Voorhees, NJ
    Posts
    4,032
    This makes no sense at all. "car drives smooth and perfect" and "getting 5mpg" just don't add up at all.

    It really could be possible that you have a small leak in the fuel system somewhere. If you follow the link in Donkey's post and the people here are very good and can most likely help. If what you've provided is the best info you can give, maybe you should take it to a shop. IMO it sounds like something is very wrong.

    Even my 350hp 375tq LT1 in my old caprice got better mpg

    (All 10mpgs shhh)
    --Anthony 2011 DGM WRX stg2+sf intake WTFtuned \_(ツ)_/

    Official Subie owner as of 01/10/11
    Stink Eye Mob #87

    Bye bye Bimmer
    Hellooo '11 REX

  10. #9
    Registered User anxiouz's Avatar
    Join Date
    Aug 2010
    Location
    So Cal
    Posts
    597
    How are you calculating "5mpg"? Does the fuel gauge needle work properly and when you fill up it goes up all the way to "Full"? How fast does it move up/down?

    One crazy idea may be that you're not actually filling up all the way...maybe there is some residue build-up or pressure or something that makes the car think you're filling up all the way but you're not. Are you definitely putting 12+ gallons in when you fill up?

    The "can't fill up all the way" issue has happened to 350Z's, Evo's, and I suspect many other cars. Just an idea I had...tough to tell with the description.
    Steve // 2010 Cadillac CTS-V // 2011 WRX hatchback (SOLD)

  11. #10
    Registered User
    Join Date
    Nov 2010
    Location
    Richmond Hill, Queens, NY
    Posts
    44
    i do 15 miles a day... 7.5 to go and 7.5 to come back from work.
    avg speed about 30mph or less.. total drive time give or take 20 minutes

    i would have 3/4 of a tank of gas going to work driving 7.5 miles on my way back it would be half a tank. im using 93 octane

    and i took it to a service shop to replace the oil 5qts mobil 1 synthetic.

    no leaks whatsoever, no burnt oil smell,
    ive had this wrx for a week now the dealer told me the O2 sensor was replaced when i got it.
    i took it to them to ask why and they told me its a "subaru" but even i know somethings wrong and i have to fix it....
    ait filter/oil/brakes/.... was done when i got it ..only thing left is sparkplugs

    if i take it to a mechanic there gonna say nothings wrong..but driving 15 miles will take out 1\4 tank of gas.....somthings wrong..

  12. #11
    Registered User anxiouz's Avatar
    Join Date
    Aug 2010
    Location
    So Cal
    Posts
    597
    Man, that's crazy. It sounds like you're running super rich but you'd notice some exhaust smoke or smell I would think.

    Is there any chance the car was modded, flashed, and then put back to stock to sell but not flashed back? Can you tell if it was modded at all? A lot can happen in 140k miles. The map may be throwing more fuel at the car expecting freed up airflow. I would try to do some data logging and see if that points to anything...see if anyone nearby has a laptop and tactrix cable or AccessPort.
    Steve // 2010 Cadillac CTS-V // 2011 WRX hatchback (SOLD)

  13. #12
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    The fuel gauge is not accurate enough to measure your gas mileage.

    Fill up the gas tank. Get a printed receipt, write Odometer on the receipt. Reset the trip OD (not necessary, but I find it handy). Drive it until the light comes on. Repeat.

    Miles driven / Gallons used = MPG

  14. #13
    Registered User xFalleNx's Avatar
    Join Date
    Nov 2010
    Location
    Voorhees, NJ
    Posts
    4,032
    Quote Originally Posted by SeattleJeremy View Post
    The fuel gauge is not accurate enough to measure your gas mileage.

    Fill up the gas tank. Get a printed receipt, write Odometer on the receipt. Reset the trip OD (not necessary, but I find it handy). Drive it until the light comes on. Repeat.

    Miles driven / Gallons used = MPG
    +1

    This is a very good start since apparently nothing at all is wrong with the car. When you say "i took it to a service shop to replace the oil 5qts mobil 1 synthetic." did you tell them about the 5mpg claim?
    If so what did they look at and/or tell you?
    --Anthony 2011 DGM WRX stg2+sf intake WTFtuned \_(ツ)_/

    Official Subie owner as of 01/10/11
    Stink Eye Mob #87

    Bye bye Bimmer
    Hellooo '11 REX

  15. #14
    Registered User
    Join Date
    Nov 2010
    Location
    Richmond Hill, Queens, NY
    Posts
    44
    hey guys thanks for all your tips =]
    the reason wht it was bad was because of a vacuum fault.. the elbow that in the intake inlet was broken that caused the air flow/ vacuum line to get limited air thus causing bad mpg..

    moving on i now have code p0302 cylinder 2 mis-fire i want to upgrade to sti coil packs on my wrx will it fit ? and will the obd computer register it as a problem ?

  16. #15
    Registered User
    Join Date
    Nov 2010
    Location
    Richmond Hill, Queens, NY
    Posts
    44
    and will it fit ?

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •