2011 wrx crazy turn signal - Page 3
Page 3 of 6 FirstFirst 123456 LastLast
Results 31 to 45 of 88

This is a discussion on 2011 wrx crazy turn signal within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by WillRXU mine does the same thing..will have the dealer check it out when I get my first ...

  1. #31
    Registered User Lightning's Avatar
    Join Date
    Apr 2003
    Location
    Delaware
    Posts
    373
    Quote Originally Posted by WillRXU View Post
    mine does the same thing..will have the dealer check it out when I get my first oil change....
    I'm not willing to drive it around like that until my first service. Call it my OCD kicking in, but I don't like it, and will be taking it in first chance I get.
    s e t h
    "If you're going to live on the cutting edge, you'd better be prepared to bleed a little."
    Stink-Eye Mob #73, Hawkeye Alliance #667

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #32
    Registered User anxiouz's Avatar
    Join Date
    Aug 2010
    Location
    So Cal
    Posts
    597
    For approx $2 for a bulb you can swap in a new one in less time than it would take to even explain the issue to a dealer. Honestly, it has got to be the easiest DIY I've ever done. Satisfy your OCD more immediately. ;-)
    Steve // 2010 Cadillac CTS-V // 2011 WRX hatchback (SOLD)

  4. #33
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    16
    No OCD here just sitting in the garage waiting for a sunny day..

  5. #34
    Registered User Lightning's Avatar
    Join Date
    Apr 2003
    Location
    Delaware
    Posts
    373
    Quote Originally Posted by anxiouz View Post
    For approx $2 for a bulb you can swap in a new one in less time than it would take to even explain the issue to a dealer. Honestly, it has got to be the easiest DIY I've ever done. Satisfy your OCD more immediately. ;-)
    Agreed, but is it just the bulb? Some things I'm reading say it's the wire going to the bulb socket having too much tension on it. I have no problem performing maintenance tasks like this, but if its a known warranty issue, I want it dealt with.
    s e t h
    "If you're going to live on the cutting edge, you'd better be prepared to bleed a little."
    Stink-Eye Mob #73, Hawkeye Alliance #667

  6. #35
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    16
    took my car of for its first oil change. they accidently tried to charge me 7 bucks for bulb....Not
    It works fine now....

  7. #36
    Registered User Lightning's Avatar
    Join Date
    Apr 2003
    Location
    Delaware
    Posts
    373
    I had mine in this morning – the service writer repeatedly asked me to describe the problem and how I knew it was a ‘known issue’ because he hadn’t heard of it. They took it back, and the tech was done inside 10 minutes. I talked to HIM outside and he said he’d done a bunch of ‘em and it was well known. That’s why I talk to techs when I can and not service writers who assume that customers don’t know anything about their cars. Maybe a Tribeca owner or something… but from my experience, WRX people always know what’s up with their cars. It’s why we’re called ‘enthusiasts.’ J
    Could I have fixed it myself? It appears so… but that’s why I have a warranty – so that Subaru fixes what’s wrong.
    s e t h
    "If you're going to live on the cutting edge, you'd better be prepared to bleed a little."
    Stink-Eye Mob #73, Hawkeye Alliance #667

  8. #37
    Registered User BertoJG's Avatar
    Join Date
    Feb 2011
    Location
    US - Little Rock, AR
    Posts
    54
    I ran into this issue on day 3 of owning my car ~ 250mi on the odometer. Mine wouldn't turn on at all.

    I replaced the bulb myself and now less than 2 weeks later only one of the filaments on the new bulb lights up sometimes and sometimes it works fine. I guess I will be pulling the battery and checking it out and moving the wire routing as I did notice it seemed snug when I replaced the bulb.

    Honestly this kinda sucks for a brand new car, but I gives me the chance to get to know her better. :-)
    Robert

    Stink-Eye Mob #1313
    2011 WRX 4 Door Ltd in DGM

  9. #38
    Registered User Lightning's Avatar
    Join Date
    Apr 2003
    Location
    Delaware
    Posts
    373
    It's not the bulb - it's the harness to the assembly. It's literally a 5 minute fix if you know what you're looking for. It was easier to let the dealer do it fast than to experiment. This IS a known issue and they know the fix - since mine was in, I haven't had the problem a single time.
    s e t h
    "If you're going to live on the cutting edge, you'd better be prepared to bleed a little."
    Stink-Eye Mob #73, Hawkeye Alliance #667

  10. #39
    Registered User BertoJG's Avatar
    Join Date
    Feb 2011
    Location
    US - Little Rock, AR
    Posts
    54
    Quote Originally Posted by Lightning View Post
    It's not the bulb - it's the harness to the assembly. It's literally a 5 minute fix if you know what you're looking for. It was easier to let the dealer do it fast than to experiment. This IS a known issue and they know the fix - since mine was in, I haven't had the problem a single time.
    That sounds promising! Too bad the service department at my local dealer, not where I bought the car, is closed on Saturdays..
    Robert

    Stink-Eye Mob #1313
    2011 WRX 4 Door Ltd in DGM

  11. #40
    Registered User Lightning's Avatar
    Join Date
    Apr 2003
    Location
    Delaware
    Posts
    373
    Quote Originally Posted by BertoJG View Post
    That sounds promising! Too bad the service department at my local dealer, not where I bought the car, is closed on Saturdays..
    Wow... I've never seen a dealer closed on Saturdays - that's a huge day for service... it's when people are free. Strange.
    s e t h
    "If you're going to live on the cutting edge, you'd better be prepared to bleed a little."
    Stink-Eye Mob #73, Hawkeye Alliance #667

  12. #41
    Registered User BertoJG's Avatar
    Join Date
    Feb 2011
    Location
    US - Little Rock, AR
    Posts
    54
    Quote Originally Posted by Lightning View Post
    Wow... I've never seen a dealer closed on Saturdays - that's a huge day for service... it's when people are free. Strange.
    I agree, there aren't that many subies around here though, we only have 2 dealers in the entire state and I picked mine up from the one 200 miles away since they were much easier to deal with..
    Robert

    Stink-Eye Mob #1313
    2011 WRX 4 Door Ltd in DGM

  13. #42
    Registered User
    Join Date
    Jun 2009
    Location
    Maryland
    Posts
    26
    Hey Gang,

    Just wondering when you all got your 2011 WRX? Is it possible this happend to only a particular batch of it it's limited to one region?

    No probs yet for me at least none that I know of.

    Thanks,

  14. #43
    Registered User BertoJG's Avatar
    Join Date
    Feb 2011
    Location
    US - Little Rock, AR
    Posts
    54
    I got mine 2 weeks ago. I'm just shy of 1k miles.
    Robert

    Stink-Eye Mob #1313
    2011 WRX 4 Door Ltd in DGM

  15. #44
    Registered User anxiouz's Avatar
    Join Date
    Aug 2010
    Location
    So Cal
    Posts
    597
    It's not a build month or region of the country issue. I've heard of mostly 2011's but also a lot of 2010's having the issue. Just because it hasn't happened yet doesn't mean anything really. But still, it's just a $3 bulb so even if it does happen it's not a big deal.
    Steve // 2010 Cadillac CTS-V // 2011 WRX hatchback (SOLD)

  16. #45
    Registered User BertoJG's Avatar
    Join Date
    Feb 2011
    Location
    US - Little Rock, AR
    Posts
    54
    Quote Originally Posted by anxiouz View Post
    It's not a build month or region of the country issue. I've heard of mostly 2011's but also a lot of 2010's having the issue. Just because it hasn't happened yet doesn't mean anything really. But still, it's just a $3 bulb so even if it does happen it's not a big deal.
    The bulb doesn't seem to be the problem, the tension on the harness seems to be. Apparently they reroute the harness so it isn't so tight if you take it in.
    Robert

    Stink-Eye Mob #1313
    2011 WRX 4 Door Ltd in DGM

Page 3 of 6 FirstFirst 123456 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •