misfire on all four and bank 1 lean
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on misfire on all four and bank 1 lean within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok first time i have posted something, but i need some help. My check engine light is on and i ...

  1. #1
    Registered User
    Join Date
    Nov 2010
    Location
    pennsylvania
    Posts
    3

    misfire on all four and bank 1 lean

    ok first time i have posted something, but i need some help. My check engine light is on and i took it to the dealership to see whats up and they said i have a missfire code for all 4 cylinders and bank 1 is lean. I replaced all my plugs and put some injector cleaner and nothing. I replaced my MAF and ran a little better but still check engine light on. Also once i get above 4000 rpm my car starts to shutter and it also did it in low rpm before i replaced my MAF. I am lost on this i would appreciate any help i could get. I have a 2002 wrx 2.0l turbo so any tips or hints on whats going on would be appreciated.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Did you reset your ECU after replacing the MAF? If you haven't, do that first, and see if the code comes back.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User
    Join Date
    Nov 2010
    Location
    pennsylvania
    Posts
    3
    i unhooked battery and hooked it back up to turn light off and then drove it about 50 miles. the light came back on after like 35 miles. I did this after i changed plugs also and it came on at 16 miles after i turned off light. But the car like studders after 4000 too and i know it is not good it shood feel alot more smooth.

  5. #4
    Registered User
    Join Date
    Nov 2010
    Location
    pennsylvania
    Posts
    3
    i also chaged my fuel filter when i changed my plugs and the only thing that is done is front mount intercooler with bov and catback exhaust. not sure what to try next.

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,295
    I Support ClubWRX
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •