Boost problems after Install
Results 1 to 5 of 5

This is a discussion on Boost problems after Install within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I installed the cobb XLE bpv last night, and i lost the two bolts the held it in. This morning ...

  1. #1
    Registered User wrx0131's Avatar
    Join Date
    Jul 2007
    Location
    Yonkers, NY
    Posts
    1,382

    Boost problems after Install

    I installed the cobb XLE bpv last night, and i lost the two bolts the held it in. This morning i bought the two bolts, and tightened it, but when i go to push my car at WOT, it only goes up to 15psi and i can feel like the car is not as fast as it was before. I made sure my intercooler pipe was in properly since that was the only thing that was removed. I also removed the bpv gasket and used silicon sealant to make a new gasket. Now, i just have to wait until it dries to go an test it. Anyone have any other ideas of what could be causing the problem? My car is tuned to 20psi, and usually runs between 18-20 depending on the weather.


    My car idles perfectly fine. My air/fuel is fine, so i know i dont have a vacuum leak or anything. Would adjusting the spring tension on the bpv do anything?

    any help is appreciated.
    Bugeye Mafia #213
    Kevin
    2002 Midnight Black Pearl WRX (Traded In!)

    2012 Ice Silver Metallic STi Sedan

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Did you adjust the spring?
    http://www.cobbtuning.com/products/?id=5065
    ADJUSTMENT
    Spring Preload - Spring preload determines the pressure differential across the BPV piston required before the BPV opens and releases the pressurized intake charge. The COBB XLE BPV can be adjusted by loosening the locknut and turning the allen-head shaft clockwise for more preload or counter-clockwise for less preload. Once preload is set, the locknut is retightened and ensures the adjustment is secure.

  4. #3
    Registered User wrx0131's Avatar
    Join Date
    Jul 2007
    Location
    Yonkers, NY
    Posts
    1,382
    Quote Originally Posted by SeattleJeremy View Post
    so should i tighten it a bit?
    Bugeye Mafia #213
    Kevin
    2002 Midnight Black Pearl WRX (Traded In!)

    2012 Ice Silver Metallic STi Sedan

  5. #4
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Quote Originally Posted by wrx0131 View Post
    so should i tighten it a bit?
    Please read the installation PDF - page 6 and 7.
    http://accessecu.com/downloads/BPVinstall.pdf

  6. #5
    Registered User wrx0131's Avatar
    Join Date
    Jul 2007
    Location
    Yonkers, NY
    Posts
    1,382
    Quote Originally Posted by SeattleJeremy View Post
    Please read the installation PDF - page 6 and 7.
    http://accessecu.com/downloads/BPVinstall.pdf
    thanks jeremy, i actually tightened it a little, and it fixed the problem.
    Bugeye Mafia #213
    Kevin
    2002 Midnight Black Pearl WRX (Traded In!)

    2012 Ice Silver Metallic STi Sedan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •