Couple of things... Please help!
Results 1 to 3 of 3

This is a discussion on Couple of things... Please help! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Alright, I changed my oil and tranny fluid to mobile 1 10w30 and 75w90 respectively... About a week after changing ...

  1. #1
    Registered User
    Join Date
    Oct 2009
    Posts
    10

    Couple of things... Please help!

    Alright, I changed my oil and tranny fluid to mobile 1 10w30 and 75w90 respectively...

    1. About a week after changing these, my fan cut through my upper radiator hose, see here
    2. After starting off in first, when I put the clutch in, the (guessing) synchro whines like crazy till I take it out of first
    3. Started noticing this today, when I start the car, the rpm's drop to ~500 and has stalled out about 4 or 5 times (3 in row this morning) and then right after I took it out of reverse.


    Could all of these things be related? I checked my trans fluid and it was a bit high, so I drained a bit from there and now its right at 'F', I replaced the radiator hose, and it doesnt have a mark on it from the fan currently, and the oil level is right between 'L' and 'F'... any suggestions help would be appreciated...


    Oh, BTW: No mods, car just turned over 100,000 >_< and begins to fall apart... thought these things were supposed to be built to last

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    21,900
    I Support ClubWRX
    Quote Originally Posted by 3n1gm4 View Post
    [*] After starting off in first, when I put the clutch in, the (guessing) synchro whines like crazy till I take it out of first[*] (
    I don't understand what "putting the clutch in" means.

    When you are NOT stepping on the pedal, so the clutch pedal is UP, the clutch is engaged, or in.

    When you are STEPPING on the pedal, so the clutch pedal is DOWN, the clutch is disengaged, so out.

    I suspect you mean the opposite though? Where is the clutch pedal when the noise happens?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Oct 2009
    Posts
    10
    Quote Originally Posted by SD_GR View Post
    I don't understand what "putting the clutch in" means.

    When you are NOT stepping on the pedal, so the clutch pedal is UP, the clutch is engaged, or in.

    When you are STEPPING on the pedal, so the clutch pedal is DOWN, the clutch is disengaged, so out.

    I suspect you mean the opposite though? Where is the clutch pedal when the noise happens?
    Fair enough,
    The clutch pedal is down, depressed, and the car is in 1st gear

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •