splattered antifreeze?!?!?!
Results 1 to 3 of 3

This is a discussion on splattered antifreeze?!?!?! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Last week I somehow got a gash in my top radiator hose which splattered antifreeze all over, so I put ...

  1. #1
    Registered User ohtwoWRXwagon's Avatar
    Join Date
    Sep 2010
    Posts
    17

    splattered antifreeze?!?!?!

    Last week I somehow got a gash in my top radiator hose which splattered antifreeze all over, so I put a new one on and thought that was the end of it. Today I noticed I'm leaking antifreeze again, it's splattered from around the alternator to the air intake but this time no leaks from the radiator hose any ideas what could be wrong???

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User GarrettKoonsman's Avatar
    Join Date
    Apr 2009
    Location
    CO
    Posts
    2,664
    check for a crack on the top plastic portion of your radiator. Very common occurance
    2003 Midnight Black Pearl WRX Sedan
    200.7 AWHP Protuned Stage 2 at 5400ft above sea level
    Bugeye Mafia Member #225
    Mods
    Pics

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by GarrettKoonsman View Post
    check for a crack on the top plastic portion of your radiator. Very common occurance
    +1.. Also check the cover of the surge tank they like to rust a tad and start to leak over time, there is actually a revised part for it ( I think a different paint was used or something ) if you ever need it replaced...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •