2000 rs swaped 04 sti trouble starting and more
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on 2000 rs swaped 04 sti trouble starting and more within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am trying to purchase an rs with a complete 04 sti swap. Saw it for the first time yesterday, ...

  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    3

    2000 rs swaped 04 sti trouble starting and more

    I am trying to purchase an rs with a complete 04 sti swap.
    Saw it for the first time yesterday, like it but am concernerd about a few things.

    When we first started the car after sittting 30 min from a 30 min ride it took a few seconds for it to fire up on the first try. Engine turn over fine just did nt fire right away. Seller stated that it was because it had low fuel. I don t beleive him does nt make sens to me. Plus the gauge was at about a quarter.

    Another thing is that the speedo does nt work he says it s the speed sensor in the tranny.Causes Revs to stop at 4500rpm. I beleive that cause the cel is on and he said the code was 25 or something like that. after reasearching on th enet I found that it is possible.

    On the test drive the car ran fine and pulled hard until 4500rpm.

    What am I looking at, what could be the real problem(s)

    I definetly wont buy the car unless it goes to red line.
    thanks
    Last edited by alzzaco; 10-11-2010 at 05:24 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2009
    Posts
    10
    I would say if it started withing 2-3 seconds of letting it turn over then yes it could be a low fuel issue. My car has trouble starting right away if its at 1/4 tank or lower and i had not drove it for a while. If you don't trust it then you need to start it, drive it, start it warm, then let it sit for a good 30 min to let it start cold again to see if it happens every time.

  4. #3
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Not sure about the slow starting issue, but the fact that the Speedo doesn't work and it will not go over 4500RPM is a RED FLAG.

    They didn't complete the swap properly, you will end up spending quite a bit of time tracking down their mistakes.

    Only buy that car if you are looking for a project to sink money in to.
    Do not buy that car if you plan on using it as a daily driver right away.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •