kind of a rediculous issue
Results 1 to 12 of 12

This is a discussion on kind of a rediculous issue within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; heeeeeello. so i go to school in buffalo, and just recently i had to change my oil. today, i went ...

  1. #1
    Registered User Sc00by_doo's Avatar
    Join Date
    Aug 2010
    Location
    Rockland, NY
    Posts
    54

    kind of a rediculous issue

    heeeeeello.

    so i go to school in buffalo, and just recently i had to change my oil. today, i went to the mechanic to get my oil changed. about an hour later, i came back to the shop to find my car was still in the garage. apparently, the bottom cover of the bumper ( the part that covers the bottom of the engine) either was popped out or he took it off (i couldn't understand him).

    anywhoo.. the big plate won't get back into position and i'm running with no protection under the front of my car.

    can someone give suggestions on how to put it back on?

    also, the little gas gauge on my dashboard has been on the past few days, what's going on!?

    (sorry for all the questions, i've been so so so busy i haven't even had time to research the problems myself)
    2OO8 WRX

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    The plate at the bottom I assume to mean the plastic protective plate. This must be removed to change the oil filter. If he can't get it back on, I really have to wonder why. It's a part with a lot of play to it so exactly what is the reason he can't get it back on?

    There's really no harm to not having it on however.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User JovicA's Avatar
    Join Date
    May 2010
    Location
    Denver CO
    Posts
    74
    i made the mistake of taking my car to a lubeshop to do my oil and never again! They just want your money and it is just cheaper to do it your self
    ME: I am losing boost its only boosting 10 instead of 15psi
    DUMDUM: I think its your booster
    ME:*thinking* your a moron

  5. #4
    Administrator TheJ's Avatar
    Join Date
    Jul 2002
    Location
    Bro do you even live in the Dirty South
    Posts
    17,785
    I Support ClubWRX
    Quote Originally Posted by teflon_jones View Post
    The plate at the bottom I assume to mean the plastic protective plate. This must be removed to change the oil filter. If he can't get it back on, I really have to wonder why. It's a part with a lot of play to it so exactly what is the reason he can't get it back on?

    There's really no harm to not having it on however.
    I'm guessing the the guy who took it off probably lost the clips that hold it on. If they didn't give you the clips back to you then you know that was the case.
    -The J
    New Members, CLICK & BOOKMARK these links:


  6. #5
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Quote Originally Posted by teflon_jones View Post
    There's really no harm to not having it on however.
    It does however protect your oil filter from catching a rock or other debris. I hate how exposed the filter is.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  7. #6
    Registered User Sc00by_doo's Avatar
    Join Date
    Aug 2010
    Location
    Rockland, NY
    Posts
    54
    Quote Originally Posted by teflon_jones View Post
    The plate at the bottom I assume to mean the plastic protective plate. This must be removed to change the oil filter. If he can't get it back on, I really have to wonder why. It's a part with a lot of play to it so exactly what is the reason he can't get it back on?

    There's really no harm to not having it on however.
    so can we bend it to get it back into place? he didn't wanna use force cause he didn't wanna break it

    and the (two) clips were with him, so i'm assuming he just took it off
    2OO8 WRX

  8. #7
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Wondering why it's not lining back up easily; is your sub frame dinged up a bit? If it is it shouldn't be difficult to make it true again.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  9. #8
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    It's just a plastic plate so bending it shouldn't be a problem. But I wonder too why it won't fit. It sounds like something in the subframe is bent.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  10. #9
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Quote Originally Posted by mudferret View Post
    Wondering why it's not lining back up easily; is your sub frame dinged up a bit?
    Quote Originally Posted by teflon_jones View Post
    But I wonder too why it won't fit. It sounds like something in the subframe is bent.
    Jinx you owe me a Porsche
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  11. #10
    Registered User Sc00by_doo's Avatar
    Join Date
    Aug 2010
    Location
    Rockland, NY
    Posts
    54
    i don't think the frame is bent. i'm about to go back to the mechanic now. i'll get back to you guys. thanks!
    2OO8 WRX

  12. #11
    Registered User Sc00by_doo's Avatar
    Join Date
    Aug 2010
    Location
    Rockland, NY
    Posts
    54
    it's set in place guys, thank you.

    it was just awkwardly angled. everything's good now.


    my fuel tank light is still on. i have half a tank of fuel in the car. is this something to be concerned about?
    2OO8 WRX

  13. #12
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Any dents in the tank? Try a different brand of gas for a tank or two, sometimes the sensors get gummed up on certain brands of gas. Just pick the "next best" brand.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •