Impreza WRX 08 hatcback, engine problem help..
Results 1 to 2 of 2

This is a discussion on Impreza WRX 08 hatcback, engine problem help.. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I bought my Subaru Impreza WRX hatchback new in 2008, and it have always have a problem with the acceleration, ...

  1. #1
    Registered User Gunleif A's Avatar
    Join Date
    Sep 2010
    Location
    Faroe Island
    Posts
    2

    Exclamation Impreza WRX 08 hatcback, engine problem help..

    I bought my Subaru Impreza WRX hatchback new in 2008, and it have always have a problem with the acceleration, it is not so easy to explaine, but in about 4000rpm it slows down and then it strougles to accelerate and then it suddently accelerate fast to about 6000rpm and slow´s down and then up to about 7000rmp and there it stops it cant go longer..... But if i use a cold air intake the car accelerate normal, Does any one know what the problem can be? it has been check by a computer and it says nothing..... does any one have the same problem??

    I think it is something to do with the airfilter sensor or something.?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Gunleif A's Avatar
    Join Date
    Sep 2010
    Location
    Faroe Island
    Posts
    2
    Does anybody know what can be the problem??

    Thanks..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •