strange noise when turbo kicks in
Results 1 to 14 of 14

This is a discussion on strange noise when turbo kicks in within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; This started this morning. After about 10 minutes of driving whenever my turbo kicks in i get this loud whistling ...

  1. #1
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72

    strange noise when turbo kicks in

    This started this morning. After about 10 minutes of driving whenever my turbo kicks in i get this loud whistling type noise, almost sounds like air shooting out (its hard to explain). I've had this car for 2 months and 3 days and this is the first time it has occurred. Has anybody else experienced this before? and any idea what might be causing it?
    THE BLOBEYE SYNDICATE #80

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,504
    I Support ClubWRX
    are you sure its not the turbo spooling?

    do you have an intake/silencer delete? they often make whistling/whooshing sounds.

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  4. #3
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72
    Well I'm not sure ha, but I've never heard the noise before which is what scared me. Its also pretty annoying
    THE BLOBEYE SYNDICATE #80

  5. #4
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Aftermarket down pipe? A little colder this a.m.?
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  6. #5
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72
    Quote Originally Posted by mudferret View Post
    Aftermarket down pipe? A little colder this a.m.?
    as far as i know its a stock down pipe, only upgrades on this was a cat back exhaust and cool air intake. it has been getting colder but it was warm last night, like 80 when it started happening
    THE BLOBEYE SYNDICATE #80

  7. #6
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,752
    Are you getting full boost? Could be a leak somewhere.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  8. #7
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,841
    I Support ClubWRX
    Quote Originally Posted by teflon_jones View Post
    Are you getting full boost? Could be a leak somewhere.
    +1 boost leak or preturbo exhaust leak.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  9. #8
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72
    Quote Originally Posted by Donkey View Post
    +1 boost leak or preturbo exhaust leak.
    What do you guess that it would cost to fix this issue if it is a bost leak or pre turbo exhaust leak
    THE BLOBEYE SYNDICATE #80

  10. #9
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,752
    Just check the hoses and you can probably find the leak. Most of them are pretty easy to replace so you could do it yourself for <$100 probably.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  11. #10
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72
    Quote Originally Posted by teflon_jones View Post
    Just check the hoses and you can probably find the leak. Most of them are pretty easy to replace so you could do it yourself for <$100 probably.
    alright cool, gonna stop by a local subaru shop and the guy will take a look. called the subaru dealership and they wouldnt even look at it without an appointment and paying some money. thank god for local shops
    THE BLOBEYE SYNDICATE #80

  12. #11
    Registered User cjm1991's Avatar
    Join Date
    Jun 2009
    Location
    st louis
    Posts
    1,040
    If its not a boost leak it could just be the CAI/cold weather. Does the car feel sluggish when building boost, or just the sound?
    Chris
    02 Camaro z28 T-Tops, m6 49k miles
    Bolt ons and tuned - 349rwhp/362rwtq
    02 Ws6 T-Top,m6 80k miles
    Bolt ons/Cam/tune - 436rwhp/424rwtq

  13. #12
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72
    Quote Originally Posted by cjm1991 View Post
    If its not a boost leak it could just be the CAI/cold weather. Does the car feel sluggish when building boost, or just the sound?
    Does feel a lil sluggish, I don't get the same feeling when I accelerate and feel the boost kick in. Wouldn't be te weather since it's been about 80-90 degrees lately here in Boise
    THE BLOBEYE SYNDICATE #80

  14. #13
    Registered User dbestballa23's Avatar
    Join Date
    Jul 2010
    Location
    Moscow, Idaho, United States
    Posts
    72
    FIXED!!!

    all it was, was the turbo sensor was unplugged. thank god
    THE BLOBEYE SYNDICATE #80

  15. #14
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    The BCS? I had a feeling it might be noise related to the wastegate, which sounds like it was, although I guessed wrong that it was cold temp related.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •