Full Boost/No Power! **HELP**
Results 1 to 4 of 4

This is a discussion on Full Boost/No Power! **HELP** within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello all, i'm new to the forum. So if this questions has been asked and there are results somewhere else ...

  1. #1
    Registered User
    Join Date
    Sep 2010
    Posts
    2

    Exclamation Full Boost/No Power! **HELP**

    Hello all, i'm new to the forum. So if this questions has been asked and there are results somewhere else please redirect me.

    My car is a '02 WRX running a AEM stand-alone, AEM cold-air, full, exhaust, uppipe, and BOV.

    It is making full boost but not giving me any power. It feels like im driving a civic. I've changed the plugs, air/fuel/oil filters, checked the MAF and CAT. I really have no idea what else is going on. Please help....

    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,708
    I Support ClubWRX
    Well is the clutch slipping then? Do the revs build but the car fails to accelerate?
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Sep 2010
    Posts
    2
    no its shifting smooth, my boost gauge says full boost but its like the boost pressure isn't reaching the engine.

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,142
    I Support ClubWRX
    Where is your boost gauge getting it's signal from?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •