changed plugs now CEL
+ Reply to Thread
Results 1 to 15 of 15

This is a discussion on changed plugs now CEL within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hello everyone im a newbi here already read alot of good stuff was hoping i could get a little help. ...

  1. #1
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8

    Unhappy changed plugs now CEL

    hello everyone im a newbi here already read alot of good stuff was hoping i could get a little help. i just bought a 06 wagon and started going threw the car to check and change fluids plugs stuff like that. i cleaned the air filter and changed the plugs this weekend with some oem replacements and the car ran great for about 20 miles then just died., i didnt here any kind of bang or crash so i pulled over and it started right back up but now my cruise control light is flashing and my check engine light is on, please help! the only mod is a cold air intake (k&n typhoon).
    Last edited by xr50pilot; 09-19-2010 at 08:27 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Welcome... post the cel codes up... the intake could be throwing off your airflow scaling, buy since you changed the plugs it might be related to that...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  4. #3
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8

    im dumb

    how do i go about getting to code #s

  5. #4
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    You should be able to have them pulled for free at auto parts stores like checker, autozone, o rilley, or napa...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  6. #5
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8
    so im ok to baby it 5 miles also is there a list of codes on the forum

  7. #6
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Yeah... you should be okay... if you post the codes we can tell you what the ecu is trying to tell you...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  8. #7
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8
    thanks if it did misfire would i be able to tell by the plug color

  9. #8
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    There might be an arc mark on the plugs... in the mean time you can check the plugs and coilpacks to make sure they are on there all the way... what kind of plugs did you use? What did you set the gap to?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  10. #9
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8
    i used the laser iridium ilfr6b (ngk) they are the same as the stock ones, the gap was set at .028 out of the box. i unhooked the batt for a few minutes then hooked it back up and took it for a ride seams fine but thats what it did the first time for about 20 miles. i didnt want to go to that far from home in case something happened. i probably lost the code by doing that, if it happens on the way to work tomorrow ill take it to autozone and have them pull the code. i was going to pull the plugs but it was getting late.

  11. #10
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Allright... sounds good... the code will pop up again eventually... just double check everything again tommarow just so its not 1 of those small things that sometimes get overlooked occasionally... your said you live in ogden... nice I live in west valley...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  12. #11
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8
    thats cool now im just waiting for the snow to fall so i can get this thing sideways and have some fun

  13. #12
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Yeah... same here, these things are a riot in the snow... IMO the perfect performance car for foul weather, especially in utah winters...lol

    Do ya have any pictures of you car?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  14. #13
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8
    no pics yet ill get some tomorrow i dont go to work until 2 pm so ill have some time i might pull those plugs in the morning

  15. #14
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Allright cool... good luck to ya... and let me know what the outcome is...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  16. #15
    Registered User
    Join Date
    Sep 2010
    Location
    Ogden UT
    Posts
    8
    will do

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •