Changing Spark Plugs Today!!! - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

This is a discussion on Changing Spark Plugs Today!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Id check out the fuel filter as well. Might not be a bad time to throw a bigger pump in ...

  1. #16
    Registered User Heide264's Avatar
    Join Date
    May 2010
    Location
    Pittsburgh, PA
    Posts
    4,169
    I Support ClubWRX
    Id check out the fuel filter as well. Might not be a bad time to throw a bigger pump in while you are at it. I still think some data logging might shed some light on the situation.

    I wouldn't wipe out the flywheel thing either. Some soobies take them perfectly, others throw cels due to some timing issue. If its running rough though, I don't think id blame the flywheel.

    Sent from my Droid using Tapatalk
    Quote Originally Posted by Trainrex
    He was throwing balloons filled with sulfuric acid and shrapnel at the swat team. They finally had to take him down with rubber bullets.
    2011 STi Build Log
    -Part 1 - Reading, Data Logging, and Analyzing Data
    -Part 2 - Turbocharger 101 & Basic Boost Control
    -Part 3 - EcuFlash, Experimental Defintions, and a Drive By Wire Intro

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Quote Originally Posted by scoobietech View Post
    Nice theory but completely out to lunch on the flywheel bit. a flashing c.e.l. is ALWAYS caused by malfunctions that will allow raw fuel to hit the cat convertors and melt them to ****.... i.e. misfires and such. the rpm/flywheel issue is a non issue as far as i'm concerned, as many people such as myself have excessively lightened flywheels. i would start with the fuel delivery system due to the fact that it only occurs at high rpm, check fuel pressure and replace fuel filter, also a good idea to verify fuel flow as limited flow will also cause this condition. if that all checks out i'd be checking ignition coils/connections.
    I said.
    Quote Originally Posted by SeattleJeremy View Post
    There are other ways to hit these codes
    Meaning the statement to follow isn't the only way to achieve this CEL condition. Then described how an excessively light flywheel could cause this problem, with a link to a thread that describes the issue. I've read a few threads about bugeyes having that issue.

    I too agree with the statement about the fuel filter. Change it, it's a cheap part, and likely way passed due.
    Last edited by SeattleJeremy; 09-17-2010 at 12:01 PM. Reason: needed another comma :p

  4. #18
    Registered User WRX-KING's Avatar
    Join Date
    Sep 2010
    Location
    408, CALI
    Posts
    22

    errr nomore misfiring?!?!?!

    okay guys now my car is no longer misfiring after 4500RPMS...i dont know what happend. now my only issue is that i am not hitting my target boost. still only 9psi....any ideas? probably boost leak eh?

  5. #19
    Registered User LetsWRCinmyWRX's Avatar
    Join Date
    Dec 2009
    Posts
    248
    OEM NGKs FTW
    Bugeye Mafia #155

    Friends don't let friends drive stock.
    Racing a neon is like fighting a girl: you can't brag about it if you win, and you don't want anyone to know if you lose.
    facebook

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •