New turbo back exhaust in a 2010 wrx sedan
Results 1 to 3 of 3

This is a discussion on New turbo back exhaust in a 2010 wrx sedan within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So i just put on my exhaust last night and when i first started it, it was fine. sounds amazing! ...

  1. #1
    Registered User 2010wrx$'s Avatar
    Join Date
    Mar 2010
    Location
    CA
    Posts
    6

    New turbo back exhaust in a 2010 wrx sedan

    So i just put on my exhaust last night and when i first started it, it was fine. sounds amazing! but when i was on my way home i was going down the freeway and all of a sudden it was like my car like stalled i dont know how to explain it. but the check engine light came on and the cruise started blinking and the traction control light cam on also?? my friend that has an evo said his evo did that too its just because i have a CAI and exhaust so theres more air and my cars computer is trying to adjust its self. is this true?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User t-time's Avatar
    Join Date
    Feb 2010
    Location
    Colorado Springs
    Posts
    35
    you need a tune for a turbo back

  4. #3
    Registered User dbya rx's Avatar
    Join Date
    Jul 2010
    Location
    San Marcos, California, United States
    Posts
    911
    read this Exhaust FAQ

    then this http://www.clubwrx.net/forums/engine...hp?t=134325261

    then this http://www.clubwrx.net/forums/engine...ad.php?t=80872

    after all that, get an effing tune before you destroy your motor
    Stink-eye Mob #814004
    2010 WRX Limited Hatch - spt short throw...for now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •