Need help fast! Power issues.
Results 1 to 2 of 2

This is a discussion on Need help fast! Power issues. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So my father has a Neon SRT4 that he is having a problem with. He is driving back home from ...

  1. #1
    Registered User loren83's Avatar
    Join Date
    Apr 2010
    Location
    Ocala, Fl
    Posts
    64

    Need help fast! Power issues.

    So my father has a Neon SRT4 that he is having a problem with. He is driving back home from being out of town and he just heard a loud popping noise and experienced an instant loss of boost. Boost gauge shows 18lbs at idle but does not move when he gives it gas. Also, the car has an HKS SSQV V1. Until now it seemed to be working properly but after the popping noise it does not make sound at all. The car has a constant whistling noise when driving it. It sounds to me like the BOV is stuck open causing him to lose boost pressure. Anyone have any advice? He needs to drive the car home but I don't want it to become damaged. Need help ASAP! Thanks.
    Bugeye Mafia Member #318.
    2003 WRB WRX w/Gold Rota SDR 17x7

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User loren83's Avatar
    Join Date
    Apr 2010
    Location
    Ocala, Fl
    Posts
    64
    Nevermind. I found the issue. The intercooler piping on the hot side came loose. Gonna get some t clamps and put it back on. You can close this down.
    Bugeye Mafia Member #318.
    2003 WRB WRX w/Gold Rota SDR 17x7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •