2002 wrx

just got the car running. there was an aftermarket alarm (viper) installed but when i bought the car the alarm would trip and go off like every 2 min... you could not even drive the car home when i bought it. long story short i disconnected the horns the alarm still trips it (flashes 2 times ever couple seconds). also the car did not come with any remotes so i just purchased 1 from the dealer 80 bucks... long story short it wont program and the alarm will not stop blinking. i tried to reset power by disconnecting power did nothing. now i have removed the the aftermarket alarm wired most of what i could wire back up but there seems to be a couple plugs as if something is missing???


long story short i have been looking at diagrams on ken gilbert and googling the crap out of this. i am completley stuck.

im trying to get the remote to program and the alarm to stop going off. what im looking for under the dash is the security module and since nothing is really labled does anyone know where this is under... passenger or driver side how many plugs go into it. the 2 plugs that are not plugged in are right behind the fuse box one plug is a 2 wire plug its red and blue wires. the other is a 3 wire fuse. there is also a wire that is a very small wire blk/red that is not hooked up to anything just tapped off. and a green connector that has 1 wire on each plug.

does anyone have any info at all or do i need to take this to the dealer i know they are going to kill me on this....


the car does start and run just would like to get things back to stock...


any info is much appreciated!