Check Engine Light On AGAIN!!
Results 1 to 9 of 9

This is a discussion on Check Engine Light On AGAIN!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So I just bought my first WRX ever and I was super excited. I bought it in Oregon and the ...

  1. #1
    Registered User sqznjuc's Avatar
    Join Date
    Sep 2010
    Location
    Olympia, WA
    Posts
    8

    Check Engine Light On AGAIN!!

    So I just bought my first WRX ever and I was super excited. I bought it in Oregon and the only aftermarket done to the car is HKS HP cat-back exhaust.

    The check engine light came on after driving it for three hours getting it home. Took it to dealer and they game me P0420(Catalyst System Efficiency Below Threshold )

    The second code was P301(cylinder 1 misfire)

    I had all new Platinum NGK plugs installed and the ECU was reset. Picked up car and it was fine for a day. Today was driving and the light came on again. Not sure what to do. The codes are back. Any help would be good. I have never been on a forum other than school. Please help and advise. The car is 2005 with only 38K miles and clean as a whissle. HELP

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,997
    I Support ClubWRX
    Are you sure you do not have a full Turbo Back Exhaust?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User sqznjuc's Avatar
    Join Date
    Sep 2010
    Location
    Olympia, WA
    Posts
    8
    I am not sure if I have a full turbo back exhaust or not? I am so new to these types of cars so I am unable to tell. Could you explain to me how to tell?

    Any reason why those codes might come on again? The new plugs are in correctly. Do catylitic converters go out often?

  5. #4
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Pop your hood and look behind the engine on the passanger side and you'll see the turbo... then look at the pipe comming off of there is your down pipe... if it looks like it isn't original then you have a full turbo back exhaust.. if so then you'll need to get it tuned, cause the previous owner probally had an access port and didn't bother to reflash a stage 2 map and hence your CEL codes...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,997
    I Support ClubWRX
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  7. #6
    Registered User sqznjuc's Avatar
    Join Date
    Sep 2010
    Location
    Olympia, WA
    Posts
    8
    Thank yo for the feedback and pictures. I used to have a honda with a motor swap. I clown on front wheel drive now. I wish I bought this type of car years ago. I lived in Arizona my whole life so I was interested. I now live in Washington State so the car is perfect. I will look tomorrow when I am off work at 11am and look at the turbo. Thanks for your help once again. If you can think of any other reason let me know.

  8. #7
    Registered User
    Join Date
    Sep 2010
    Posts
    1

    RE:Check Engine Light On AGAIN!!

    Hi,
    Actually in car the most common problems that trigger the light are emission control malfunctions. The emission control system is what your car uses to try to keep our air a little cleaner. To do this, it employs dozens of sensors, valves, flaps, heated wires and probably some fairy dust.

  9. #8
    zax
    zax is online now
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,678
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by Fairban View Post
    Hi,
    Actually in car the most common problems that trigger the light are emission control malfunctions. The emission control system is what your car uses to try to keep our air a little cleaner. To do this, it employs dozens of sensors, valves, flaps, heated wires and probably some fairy dust.
    holy crap the spammers are getting more specific!


    OP, recognize this is spam. Your CEL doesn't have anything to do with the EVAP system
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  10. #9
    Registered User sqznjuc's Avatar
    Join Date
    Sep 2010
    Location
    Olympia, WA
    Posts
    8
    Went to another mechanic today and he told me to first go to muffler shop to deal with the P420 code. So went to muffler shop in Lacey, WA and the guy was way cool. Got me right in and looked at the car for FREE!!!!! He informed me that the stock cat was toast. He took some gun thing to test the temp read out and it was dead he said. So I then went to Subaru dealer and told him what the problem was and he informed me that the stock cat is still under warrenty. So I now have an appointment next Thursday to have that taken care of. After that I will have the P301 code taken care of. Someone told me that the cap might be bad on the spark plug(hmmm). Any thoughts? Thanks for everyone who has helped me. The picture setup was awesome for showing me in detail about my engine. Thank You!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •