brake light shows up on cluster?
Results 1 to 5 of 5

This is a discussion on brake light shows up on cluster? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Just started the car this morning found out that my brake light stays on when I pulled the ebrake handle. ...

  1. #1
    Registered User
    Join Date
    Aug 2010
    Location
    stockton ca
    Posts
    20

    brake light shows up on cluster?

    Just started the car this morning found out that my brake light stays on when I pulled the ebrake handle. Hmmm. Im just gonna take a guess I think it maybe my rear disc brakes is going out. Plz. Poet me up if I'm wrong.. what to do?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,014
    Check the brake fluid reservoirs level. Make sure it is not low. If that is good maybe the e-brakes switch is not working properly.
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  4. #3
    Registered User
    Join Date
    Aug 2010
    Location
    stockton ca
    Posts
    20
    Yea dude I checked the fluids it show that its rite above the line of min (barely ) but check been searching around its said I probably need to replace my rears pads.

  5. #4
    Registered User d_Ziggy_2000's Avatar
    Join Date
    Jun 2010
    Location
    Seattle(ish)
    Posts
    593
    I agree with the brake fluid check... but if neither of those work... try the tension on the break cable to see if it is fully releasing
    '88 Sub Justy *Rock in oil pan killed on freeway
    '87 Honda Civic *Bad pistons (to lazy to fix)
    '85 Nissan 200sx *Blown engine drifting
    '00 Sub Outback *Mother literally stole
    '92 Toyota Tercel *Hated it
    '02 WRX '07 kawasaki ninja. * current

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,841
    I Support ClubWRX
    Quote Originally Posted by evo-killer209 View Post
    Yea dude I checked the fluids it show that its rite above the line of min (barely )
    And that would probably be why the light is on. There is a level sensor in the master cylinder. Generally if the fuid is low the calipers have expanded out so far because your pads are getting thin. You need to check both the front and read pad thickness. If they are with in spec then check for leaks. If no leaks then just top off the fluid.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •