Help please!
Results 1 to 4 of 4

This is a discussion on Help please! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Alright i have a 03 with 54k and i have been hearing a noise. When i make a hard right ...

  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    17

    Help please!

    Alright i have a 03 with 54k and i have been hearing a noise. When i make a hard right turn it sounds like somethings either rubbing or dragging from the left front wheel area. I looked but didnt see much. Any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Well first of all take a peek under the car and see if you notice anything rubbing such as a splash shield or something..From what your saying it kind of sounds like either a splash shield rubbing, or the ridge on the backing plates of the rear brake rotors are contacting the backing plate ( common occurrence )...what kind of sound is it? Is it more along the lines of a grinding? Are you 100% sure it is coming from the front and not the rear?

  4. #3
    Registered User
    Join Date
    Jun 2010
    Posts
    17
    Well im not 100% sure its coming from the front but i do know its when i make a right turn and the noise comes from the left side, sounds like metal on metal grinding, and when going down side streets at a slower speed i can kinda hear the rubbing.

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by 03bugwrx View Post
    Well im not 100% sure its coming from the front but i do know its when i make a right turn and the noise comes from the left side, sounds like metal on metal grinding, and when going down side streets at a slower speed i can kinda hear the rubbing.

    I would go over your entire brake system first, just check everything, I have a feeling its the brake backing plates like I mentioned before, however your pad life could be wearing down or you could have something as simple as a small pebble in between the backing plate and the rotor ( yes, I have seen this before )...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •