2004 Subaru WRX Cluster Gauge 4 Bulbs die together
Results 1 to 3 of 3

This is a discussion on 2004 Subaru WRX Cluster Gauge 4 Bulbs die together within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, This is my first post. It seems my backlighting for when I have my low beams on blewout ...

  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    4

    2004 Subaru WRX Cluster Gauge 4 Bulbs die together

    Hey guys, This is my first post.

    It seems my backlighting for when I have my low beams on blewout (i.e., there is no amber/orange background light). I count 3 blue socket bulbs (85066GA390) and 1 red socket bulb (85068SA000) burnt out. I believe the red socket bulb is a backlight for the LCD? Before I replace these I was wondering if anyone had experienced this before on this model? If so did a fuse blow also?

    Thanks guys,

    qshot

    Recent Car History
    March and April 2010 - low beams replaced
    July 2010 - PDR of hail damage at body shop
    August 2010 - backlight went out after I switched on low beams for first time after I got my car back from body shop.

    Multimeter shows ~1.7 volts across terminals for one of the blue socket bulbs when it should be on (assuming on is 14volts). In WI-89 to WI-92, I do not see any fuses shown in the wiring diagram for the control module.

    Aug 13, 2010 status update
    Pin C9 is approx 12 volts away from C6 on the cluster panel. I am assuming a bad wiring connection (i.e. floating ground).
    Swapping relays and fuses has made no difference in voltage across light bulb socket.

    Aug 15, 2010 status update
    The light dimmer control for the backlight was turned on and it added the resistance which made C9 not equal to C6. This has been corrected and the lights are brighter.

    There is no obvious reason for the bulbs going bad but I think its time to replace the car battery.
    Last edited by qshot; 08-15-2010 at 04:27 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Best be sure to check all the fuses before replacing the bulbs.
    Have you recently jump started the car? How is your battery doing?

    It's very strange to have all four bulbs go out at once.

  4. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    4
    Quote Originally Posted by jeremy96gase View Post
    Best be sure to check all the fuses before replacing the bulbs.
    Have you recently jump started the car? How is your battery doing?

    It's very strange to have all four bulbs go out at once.
    I did not jump start the car recently. Last time was last winter.

    Battery is subaru OE. I assume it is okay. Will check with multimeter.

    I'll check the pcb voltage for the bulbs before I install any new bulbs.

    Thanks,

    qshot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •