Lots of smoke, Rough idle
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Lots of smoke, Rough idle within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am helping out a buddy and he has a big problem with his car. 2002 wrx 2.0 stock internals ...

  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    2

    Lots of smoke, Rough idle

    I am helping out a buddy and he has a big problem with his car. 2002 wrx 2.0 stock internals and turbo but lots of other aftermarket goodies. He just got the car a couple weeks ago. The car runs it smokes very badly and has misfires on all 4 cylinders. I did a combustion gas test in the coolant and it passed that. The oil looks very clean as does the coolant. He told me he was driving it and had the boost on high which is around 20 and all of a sudden it started smoking and running real ****ty. Is there any way that the turbo seals could be leaking oil in the exhaust and the misfire is because the turbo is bad. It seems ok just off of idle but still smokes very badly, not driveable.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Skreekin's Avatar
    Join Date
    May 2005
    Location
    Bellingham, WA
    Posts
    1,582
    Is it tuned in anyway? Have you pulled the plugs? What goodies does he have? Was it running this way when he bought it? What are the codes??
    2005 WRB WRX Stage 2
    Blobeye Syndicate #76
    A Must Read http://www.clubwrx.net/forums/engine...do-not-do.html

  4. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    2
    Yes it was tuned. It ran good when he first got it and he can no longer drive it. I havent pulled the plugs yet but they wouldnt make it smoke like this. It had a p301, p302, p303,p304 which are all misfire codes on all cylinders. It has an exhaust, intake, header, intercooler, radiator, intercooler hoses, bov, turbo timer, a couple other things. I havent worked much on a modded subaru. I just wonder if a turbo seal could do something like this or if its internal engine (bearings, valve, cam, pistons, head gasket). There is some noise but most appears to be in the bell housing area. It has a lightweight flywheel, i was thinking noise could be flexplate flex from misfiring motor.

  5. #4
    Registered User Skreekin's Avatar
    Join Date
    May 2005
    Location
    Bellingham, WA
    Posts
    1,582
    Maybe your timing belt tensioner has worked itself loose causing the belt to slip a bit. Or could be your coil packs. Does the CEL rotate from cylinder to cylinder, or does it give misfire codes for all four at the same time?
    2005 WRB WRX Stage 2
    Blobeye Syndicate #76
    A Must Read http://www.clubwrx.net/forums/engine...do-not-do.html

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •